WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Slow Slimstat – Large DB?

[Resolved] Slow Slimstat – Large DB?

  • Statistiker
    Member

    @statistiker

    Dear Camu,

    My page loads quite slowly and needs a long time (about 1.5s) for admin-ajax.php independent of whether I am logged in or not. By devactivating i found out that slimstat is most likely the reason for that. I read quite a few threads here but all of the solutions could nt help me with my problem.

    Actually I never deleted entries in my database and have now about 570k rows and a total amount of 110 MB. Could it be the reason for the slow loading times? Before I make a backup and delete old data I wanted to be sure, whether it’s worth the effort!

    Thank you for your advice!

    Best regrads,

    Statistiker

    By the way, I already reviewed Slimstat the last time I had a problem.

    https://wordpress.org/plugins/wp-slimstat/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jason Crouse
    Participant

    @coolmann

    I am pretty sure that would be the reason. It also depends on how your db server is configured. Are db indexes enabled in WP SlimStat?

    Statistiker
    Member

    @statistiker

    Hello Camu, thanks for the quick answer. Where is the setting for enabling db indexes? Or to answer your question, it’s set to default 😉

    Let me please ask you another question: The last tab on the settings menu i guess it’s name is debug in English offers an option simply called Performance. It’s directly loacted under the “No Panic button”. The description reads as follows: “Improve Performance Please note that you will need about 30% more DB space to store the extra information required.”

    Will this option improve my situation or does it make it worse? Also is it reversible?

    Again thank you so much, I always get here a great support!

    Plugin Author Jason Crouse
    Participant

    @coolmann

    Yes, ‘Improve Performance’ activates a few indexes that help MySQL retrieve the data quicker. Try that and see if it helps. The setting can be reversed, so no worries.

    If that doesn’t help, I would backup all the data and empty the tables.

    Plugin Author Jason Crouse
    Participant

    @coolmann

    By the way, version 3.5.6 is going to make a huge difference, especially if you’re using InnoDB as your db engine of choice. We just added some new optimizations (thanks to a MySQL employee who spent some time reviewing our db structure) that will make your reports… fly! Contact us if you want to test this new version in advance!

    Statistiker
    Member

    @statistiker

    Dear Camu,

    thank you for your answer. Just pressing the increase performance button helped not much, actually I noticed no difference.
    My problem is not concerning the load time of reports, because I can wait, but the normal homepage is loading slow.

    I guess version 3.5.6 will come out anyway so let’s give it a try. By the way Slimstat is reporting MyISAM as a db engine.

    Plugin Author Jason Crouse
    Participant

    @coolmann

    Switching to InnoDB (via phpmyadmin) could make a difference. If it doesn’t, then your DB server might not be properly configured, or just not adequate to handle big datasets.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] Slow Slimstat – Large DB?’ is closed to new replies.