WordPress.org

Forums

Slow site! Can't figure why... HELP (6 posts)

  1. luke_conker
    Member
    Posted 2 years ago #

    My site - http://www.itsoffishial.com - is running slower than I'd like. Slow enough to make me think there is an easy solution...

    I have tried deactivating plugins and reactivating one-by-one and couldn't find the problem...

    Any help you guys could offer would be hugely appreciated!

    Luke

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    See report: http://gtmetrix.com/reports/www.itsoffishial.com/JW1QXhkS
    Your site loads in 1.74 seconds - not bad, while there is scope for improvement. Optimize after going through the report. Also, you may try a caching plugin like http://wordpress.org/extend/plugins/wp-super-cache/

  3. luke_conker
    Member
    Posted 2 years ago #

    Thanks Krishna.

    When I run the test on Pingdom tools it comes out a lot slower...

    and when I try to load the site in firefox or safari it takes a lot longer than other sites...

    Any idea why this is?

    x

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    It loads fine for me in Firefox. Anyway, try the plugin I suggested. Also, try to optimize images.

  5. luke_conker
    Member
    Posted 2 years ago #

    Thanks Krishna, its awesome that people like you respond so fast.
    x

  6. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    You are welcome! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags