Support » Plugin: WooCommerce » Slow site and lot of warning messages

  • Resolved mj99

    (@mj99)


    Hi,

    [See spec at bottom of the message]

    We have get tired of slow webhosts and setting up an own server in house. I have export/import the old site and have the server up for test and tuning.

    The site is slow when browsing the categories so i tried to set debug on and “show errors” in wp-config.

    When browsing sites with debug on all errors and notices are shown for the user. I get tons of something like this (part of it is in Swedish but i think u all understand the meaning);

    Notice: wc_add_to_cart_params har upphört sedan version 3.4.0! Använd woocommerce_get_script_data istället. in /usr/share/nginx/html/wp-includes/functions.php on line 4091

    New HP 16 core, 92GB ram
    Centos7
    Mariadb 10.1.33
    Nginx 1.13.12
    PHP FPM with OPCache 7.1.18

    WP + Plugins;
    Wordpress 4.9.6
    Woocommerce 3.4.0
    SveaWebPay Gateway 2.9.3 (This is the payment plugin from Swedish company SVEA)

    Of cource we have other plugins to, but i have tried to remove (COMPLETE REMOVE) all other plugins. It’s woocoommerce or “SVEA WebPay” that put this warnings out.

    If i deactivate Svea webpay it runs a lot faster with no errors. I have been in contact of the plugin vendor (a advertising agent company) but they said they can not reproduce the error.

    What do you guys think. I have Google a lot and find other ppl with similar problem but no solution.

    // Magnus

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • You need to find from where wc_add_to_cart_params() is called. It might be in some plugin, but it can also be in the theme you’re using.

    WooCommerce generates that notice to inform you that the wc_add_to_cart_params filter has been deprecated since WC3.4.0. One of your plugins or your theme is using that filter. The plugin or theme needs to be updated to use woocommerce_get_script_data instead.

    I also see this notice: Notice: WC_Cart::get_cart_url har upphört sedan version 2.5. That is a really outdated theme (or plugin) file!

    Check your WC System Status Report to see if your theme has outdated template overrides.

    TIP: Set WP_DEBUG_DISPLAY to false and WP_DEBUG_LOG to true. Then debug messages will not be visible on the web page, but written to /wp-content/debug.log instead.

    Plugin Support RK a11n

    (@riaanknoetze)

    Thanks @josk79 and @tobifjellner for helping out – much appreciated 🙂

    Thread Starter mj99

    (@mj99)

    Hi,

    Thank you all for input and tips! I have manual make changes in our theme because the theme-maker is not longer active.

    Big thanks. I now get 96 in Google pagespeed!

    Se you out there,

    Magnus

    • This reply was modified 3 years, 5 months ago by mj99.
    • This reply was modified 3 years, 5 months ago by mj99.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Slow site and lot of warning messages’ is closed to new replies.