WordPress.org

Ready to get started?Download WordPress

Forums

Slow Site (3 posts)

  1. lofistl
    Member
    Posted 9 years ago #

    Okay I have read some of the other topics here on slow performing sites. And I don't think I'm having the same problem. My main page seems to load fairly quicky I know I have some issues with optimizing the embeded flash video but I don't think that's the issue, or at least the main one--and I'm working on that. And I don't think it's any funky plugins that I'm using--because I'm not using much of anything more than what comes standard. Anyway anytime I request an archived page, or anything beyond the scope of the front page it takes forever to load. Which makes me think that it's a database issue. Am I bumping up against the limits of what Dreamhost can handle on a shared hosting plan? I've been bruning up a lot of bandwidth lately, over 10 gigs a day (seems like a lot to me anyway) but that's mostly just requests for static .mov files on the RSS feed. I dunno, I upgraded to 2.01 thinking that might help but no dice. Anyone have any idears?? Oh and comments seem to load really slow too.

  2. davidchait
    Member
    Posted 9 years ago #

    disabled all extra plugins?
    tried commenting-out in php /**/ instead of html commenting (where the code still exectutes AND outputs -- just look at your page source!)?
    tried WP-Cache?

    -d

  3. niziol
    Member
    Posted 9 years ago #

    I think you've got it backwards, your front page is VERY slow, all of those videos you're trying to load, way too much. Not even the first one finished for me, I stopped it at 25 seconds and I am on a broadband connection.

    The archives loaded just like they should. Perhaps the very large amount of bandwidth your front page uses is slowing everything down? I would also suspect that the flass loads quickly for you because it's cached in your browser.

    Putting the following code on your page somewhere, like in the head, it will leave an HTML with the number of queries and time it took for WordPress:
    <!--<?php echo $wpdb->num_queries; ?> queries executed in <?php timer_stop(1); ?> seconds-->

    I think it's the flash, it's just way too much. People who are impatient or on a slow connection would probably give up before it ever finished.

    Good luck,
    Michael.

Topic Closed

This topic has been closed to new replies.

About this Topic