Support » Plugin: Google Pagespeed Insights » Slow reporting

  • It’s been almost 3 days plugin is running in the background and so far only 5 of 240 pages (selected in OPTIONS) been reported back from Google.

    Plugin often returns this:

    “There are no new pages, or pages with expired pagespeed reports to recheck. To force a recheck of all pages, check the “Recheck All” box before starting reporting.”

    Maximum Execution Time: 30 minutes
    Maximum Script Run Time: No Limits
    Report Throttling Delay Time: selected all values but stick with 180 seconds
    Report Status Indicator Refresh Rate: Fast

    Thank you for any hint/advice.

    • This topic was modified 9 months, 3 weeks ago by milosmili1234.
Viewing 1 replies (of 1 total)
  • Plugin Author Matt Keys

    (@mattkeys)

    Hey @milosmili1234,

    That kind of speed is definitely not normal, and is most likely indicating that something on your server is killing this process before it can complete.

    Many hosting providers put hard time limits on scripts in the server configuration that cannot be disabled or overridden by plugins. These limits exist to some extent in most servers but are especially cumbersome in lower-cost and shared hosting environments where the timeout values are typically even shorter.

    My advice would be:

    1. Set your throttling delay back to zero
    2. Set the “Maximum Script Run Time” down to a value of 45 seconds
    3. Try running reports with that value, and see if reports are able to be completed before the server kills the process. If reports seem to be running well, you can try increasing the Maximum Script Run Time to the next largest value and see if they can still complete without being killed. If reports still do not complete try a lower value.

    Unfortunately most hosting providers consider their server configurations confidential and do not share the actual values publicly, so this kind of trial and error is the best way to figure it out.

    I hope this helps!

Viewing 1 replies (of 1 total)
  • The topic ‘Slow reporting’ is closed to new replies.