Support » Plugin: WP Private Content Plus » Slow Query on Plugins Page

  • Resolved jstraete

    (@jstraete)


    Whenever I load my plugins page, it will always take around 10 seconds to load. I got a plugin called Query Monitor that has now helped me identify the culprit. Here is the query info:

    Query:
    SELECT *
    FROM wp_posts
    WHERE post_status = ‘publish’ and post_content like ‘%[wppcp_private_content%’

    Caller: WPPCP_Admin_Stats->get_private_shortcode_data()
    Rows: 2
    Time: 6.812 seconds

    There is also a PHP error that shows up when loading this page:
    Level: Notice
    Message: Undefined index: wppcp_user_assign_group_nonce_field
    Count: 1
    Location:
    1. do_action(‘init’)
    wp-settings.php:525
    2. WPPCP_Groups->add_user_group()
    wp-includes/class-wp-hook.php:286
    3. wp-content/plugins/wp-private-content-plus/classes/class-wppcp-groups.php:325

    Any help in resolving this to prevent this query from running or speeding it up would be greatly appreciated as the plugin is great otherwise. Thanks!

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Also have this notice:
    Undefined index: wppcp_user_assign_group_nonce_field 1
    +
    wp-content/plugins/wp-private-content-plus/classes/class-wppcp-groups.php:325

    Plugin Author nimeshrmr

    (@nimeshrmr)

    Hi

    Please go to Private Content Settings -> General Settings section and check if Enable Dasboard Restriction Stats settings is selected. If so. remove the selection and save the settings

    LEt me know if you still get this issue after that

    Thanks

    For me this option Disabled
    I have PHP warning on main site page:
    Undefined index: wppcp_user_assign_group_nonce_field 1
    +
    wp-content/plugins/wp-private-content-plus/classes/class-wppcp-groups.php:325

    lordrubis

    (@lordrubis)

    Up

    jstraete

    (@jstraete)

    This option has been disabled for me also already, so that setting isn’t what’s causing this issue for me.

    This issue is still not fixed yet.

    Plugin Author nimeshrmr

    (@nimeshrmr)

    This is fixed now with version 2.11.

    Plugin Author nimeshrmr

    (@nimeshrmr)

    This is fixed now with 2.11.

    I just updated the plugin this morning and now my wp-admin area doesn’t work (for instance, if I try to go to https://www.newhollandrochester.com/wp-admin and login, I can’t get logged in).

    The front-end of my site works, but none of my pages marked private work. I was on version 2.01 previously I believe. I just changed the plugin folder name from wp-private-content-plus to wp-private-content-plus-disable and now my private pages work again, but the content marked privately with this plugin is no longer working. Please help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.