Support » Plugin: WooCommerce » Slow query issue “Create Table for Woocommerce Blocks”

  • Resolved diegpl

    (@diegpl)


    Hi, a slow query shows up in Query Monitor plugin, and I do not even work with Gutenberg, I even have the “No Gutenberg – Disable Block Editor – Back to Classic Editor” active. And I do not have the Woocommerce Blocks plugin installed either, what makes the issue really sounds like a bug.

    Automattic\W\B\Installer->maybe_create_table()
    wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Installer.php:93
    Automattic\W\B\Installer->maybe_create_tables()
    wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Installer.php:64
    Automattic\W\B\Installer->install()
    wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Installer.php:27
    do_action(‘admin_init’)
    wp-includes/plugin.php:478

    That is happening in the last version (4.3.0).

    Is there a way to fix this slow query I believe should not even actually run? Does someone know if the team is already taking a look or should we talk about how to improve the code ourselves and give it to the team? Tks! 😉

    • This topic was modified 1 year, 2 months ago by diegpl.
Viewing 3 replies - 1 through 3 (of 3 total)
  • For reference @diegpl raised this issue in the WooCommerce blocks support forums already. Along with that was also mentioned here that this is being seen on every page load.

    @diegpl are you seeing any notice appear in the dashboard as well or just this information showing up with the Query Monitor plugin?

    As I noted in the other thread, any notification about this particular code executing should at most only appear once in the dashboard unless there was an issue with creating the table (in which case there would be a notice in the dashboard as well).

    Can you share some more details about your environment. Is this a multisite install?

    Thread Starter diegpl

    (@diegpl)

    It is a multisite with around a thousand site. The issue was diagnosed because the poor loading performance I realized in the server and though query monitor.

    https://github.com/woocommerce/woocommerce-gutenberg-products-block/issues/2885 – the solution is here, please, request it there as well to be implemented. My partner, who is a great programmer, proposed it and it worked very well in our server 🙂
    Tks! 😉

    Plugin Support Tseten D a11n

    (@tibetanitech)

    I’m glad you were able to locate the solution and it worked for you. I see that you’ve added a comment in the GitHub issue as well.

    I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Slow query issue “Create Table for Woocommerce Blocks”’ is closed to new replies.