WordPress.org

Support

Support » How-To and Troubleshooting » Slow Performance – Initial Page Load Delay

Slow Performance – Initial Page Load Delay

  • I’m currently trying to determine why my WP blog is loading so slowly.

    When trying to access the homepage, you can’t help but notice a 3-4 second delay before the page loads. This is shortened by deactivating all plugins to < 1 second. I began using the Firefox Page Speed addon and was able to see this delay graphically.

    My question is, referencing the Plugin API/Action Reference, is it safe to say that my website is getting bogged down with plugins during the “plugins_loaded” action?

    If so… is there anyway to speed this up?

Viewing 3 replies - 1 through 3 (of 3 total)
  • daveevolve

    @daveevolve

    Did you ever find a solution to this. I just posted a similar problem. I went through turning off plug ins, reinstalling, etc and nothing worked.

    Are you having any issues with a slow admin?

    I did figure out my problem, but it was self inflicted. In a nutshell, I was using query_posts when i should have been using get_posts to create multiple loops on my homepage. This caused multiple loops to be created which slowed things down tremendously.

    That was the biggest problem. I used a plugin called WP Tuner to help me see which areas were slowest and after some sleuthing was able to put the issues to bed.

    I also noticed that though I love all the great plugins out there for WP, not everyone takes the time to optimize them. 😉 So systematically deactivating them and using WP tuner helped there alot too.

    No issues w/ a slow admin.

    I came across this post while searching on why my site had a constant delay of appr. 3 sec’s before loading. In another post i found these plugins:
    http://lud.icro.us/disable-wordpress-core-update/
    http://lud.icro.us/disable-wordpress-plugin-updates/

    The site loads instantly now. Of course you will have to make sure to stay tuned with possible updates manually now, but the performance difference is worth it for me.

    From +/- 3 secs down to 0.65 now according to Yslow

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Slow Performance – Initial Page Load Delay’ is closed to new replies.
Skip to toolbar