• bug9324

    (@bug9324)


    I really like this plugin, but for some reason (if the page is not cached in the ql-cache folder) it takes several minutes to load (it can reach more than 10 minutes on longer posts).

    If I disable the plugin the page loads quickly. Not sure what is happening here. I’m using wordpress 5.7.1 and have virtually no traffic on my server.

    Any tips or suggestions what I could try to fix this?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author advanpix

    (@advanpix)

    You must cache formulas on your server. Plugin shows the warning if cache is not used, please follow its instructions and enable it.

    Serving thousands of small images over HTTP is very very slow. This puts a lot of load on QuickLaTex server which is not designed for this. You must cache images on your server.

    Plugin Author advanpix

    (@advanpix)

    Also, after looking to your webpage, I would suggest using special plugins to optimize your pages – WP Super Cache and Autoptimize. Now your server is not optimized for high speed at all.

    Thread Starter bug9324

    (@bug9324)

    Thank you for the reply.

    I have always used caching on my server, but when I open a page that I haven’t opened in a while the load time is as stated, so I assumed the images were removed from the cache directory after some time and rendered again.

    I have installed the plugins and see no immediate improvement. Maybe after the first rendering it will work better in the future.

    Thread Starter bug9324

    (@bug9324)

    Hi again.

    After I wrote the above comment I clicked on every blog post to re-render the equations in the cache directory and my site was pretty responsive. Then for some reason it stopped looking for (or not finding) the cached images, and pages are again rendering slowly.

    I’m not sure what to do at this point… any suggestions would be much appreciated.

    Plugin Author advanpix

    (@advanpix)

    Most probably you have changed something in the global preamble or other QuickLaTeX settings. It is the only case when it purges cached images and re-creates them from the start.

    Thread Starter bug9324

    (@bug9324)

    Thank you for the reply, I’ll see what I can do.

    I did reinstalled QuickLatex, cleared the cache and re-rendered all the posts three weeks ago. The only thing I touched in the settings is the latex preamble which reads:

    \usepackage{amsmath}
    \usepackage{amsfonts}
    \usepackage{amssymb}
    
    \newcommand{\Q}{\mathbb{Q}}
    \renewcommand{\H}{\mathbb{H}}
    \newcommand{\R}{\mathbb{R}}
    \newcommand{\C}{\mathbb{C}}
    \newcommand{\N}{\mathbb{N}}
    \newcommand{\Z}{\mathbb{Z}}

    Most of the files in the ql-cache directory are about three weeks old also, so I’m not 100% sure anything is being purged.

    The most confusing part is that when I opened a couple of those older png files in the cache directory I was able to deduce which post they came from. I opened the blog post and it took several minutes to load anyway and new files were added to the ql-cache directory. These new files were duplicates of the old files with new names.

    Plugin Author advanpix

    (@advanpix)

    @”The only thing I touched in the settings is the latex preamble…”
    Plugin must re-generate all the formulas after changes to global preamble.
    It doesn’t delete the old files in a cache, since you might undo the changes (in preamble or in formula, etc.). In this case old images will be re-used from cache.

    There is nothing confusing here, this is just how cache works.

    • This reply was modified 2 years, 11 months ago by advanpix.
    Thread Starter bug9324

    (@bug9324)

    Ahhh, ok I see, this explains it.

    Thank you!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Slow page rendering’ is closed to new replies.