WordPress.org

Forums

JW Player for Flash & HTML5 Video
Slow loading of external videos from CDN (13 posts)

  1. greggdavis
    Member
    Posted 1 year ago #

    The JW Player plugin loads our video so slowly and seems to be stalling - this happens MOST but not all of the time. I am loading the video from a fast CDN at Rackspace, so that's not the problem. URL example here: http://aretethrowsnation.com/arete-throws-nation-mini-clinic/

    Can you help?!!

    https://wordpress.org/plugins/jw-player-plugin-for-wordpress/

  2. greggdavis
    Member
    Posted 1 year ago #

    I am using an external URL to embed the video into the player, using the media library.

  3. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    This plays quickly for me, did you solve this issue?

  4. greggdavis
    Member
    Posted 1 year ago #

    Thanks for your quick reply - no, it it still hanging up, and it's pretty unpredictable. Sometimes it loads fast for me, other times it takes maybe 15-30 seconds to start playing, and clients have reported the video "hanging" or stopping periodically. I was hoping you might have an idea why and a quick fix. Can I give you any more details that might help troubleshoot? Thanks again, I appreciate your keeping up with the plugin.

  5. greggdavis
    Member
    Posted 1 year ago #

    With a little testing I've found that it might me our membership protection that could be delaying the loading of the video. We are using Wishlist Member to protect videos for members only using their shortcodes. I don't see how this would affect it, but the video player and the screen image load right away, and the video usually takes a long time to load when the play button is clicked. Is this something you may have heard about?

    Thanks again --Gregg

  6. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    I have not heard of an issue like that before. I was using Firefox 27 on Win7, which renders in HTML5 mode, and it played quickly. What OS / Browser are you using?

  7. greggdavis
    Member
    Posted 1 year ago #

    I'm also using Firefox 27 on Win 7. It seems pretty unpredictable, and that's why I asked you about it. Sorry I don't have more details. It's possible that having more than one video on a page, as in a Category listing page, was making it happen. Have you heard of any issues with that?

  8. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    I haven't. What if you disable the membership plugin to test, though?

  9. greggdavis
    Member
    Posted 1 year ago #

    There are videos both protected and not protected. I can't disable, the membership is live.

    But with my testing, the videos load slow about half the time, and others are experiencing the same. I wonder if there's a plugin conflict.

    We are moving towards a Vimeo Plus service instead of the player for now.

    Thanks for your efforts here.

    Gregg

  10. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    One thing to try is to set the primary rendering mode to flash in the plugin settings.

  11. greggdavis
    Member
    Posted 1 year ago #

    OK thanks - if I do that, will the player still go to HTML5 for iOS devices?

  12. greggdavis
    Member
    Posted 1 year ago #

    Hmm, after I did that, I just observed the player load the entire video before beginning to play.

  13. JW Player
    Member
    Plugin Author

    Posted 1 year ago #

    Hm, it might have to do with how your videos are encoded. I would try running your videos through this tool - http://renaun.com/blog/2010/06/qtindexswapper-2/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic