Support » Fixing WordPress » Slow loading frequent 404 errors from admin end – tried everything!

  • poorlittlefish


    I’ve had my WordPress site running for about 18 months and, other than the first month when I was uploading a lot of content, everything has stayed the same in terms of pages, plugins and theme. All I’ve done is update WordPress and plugins when needed.

    Since July, though, my site has become insanely slow, with the majority of the wait time seemingly just on connecting to the server (just getting to the login page takes about 20 seconds). I don’t have problems with any other sites. Also, when trying to work on my site, I was getting internal server error messages about 50% of the time. The hosting company replaced the .htaccess file and now those errors have been replaced, with the same frequency, by 404 errors. Whether updating a page, viewing the page list, updating a plugin – anything – half the time the wait results in a 404 error.

    I have…
    *Deleted unused plugins, deactivated others
    *Tried the W3 Total Cache plugin (the hosting company tried to blame that for causing the problem, even though I’d installed it BECAUSE of the problem!)
    *Tried the NextGEN Optimizer plugin for my gallery
    *Reduced the number and size of images on the home page
    *Increased the memory in the wp-config file to 1024
    *The hosting company has increased the memory to 1024 in the php.ini file
    *Repaired and optimised the database

    Despite trying all this, there has been no improvement. Nothing about my site has changed in well over a year, yet the hosting company can’t/won’t pinpoint anything that happened their end in July to suddenly cause these frequent 404 errors and terrible slow loading that I’ve experienced from then onwards.

    I suggested a problem with scripts being killed off prematurely, but the hosting company reckons that the memory increase should have stopped all that. Surely no WordPress site should require 1024mb memory anyway? Regardless, my site had been working just fine without increased memory until July, so I don’t see how these problems can have been caused my end when I’d made no changes.

    I’d be grateful to hear any other suggestions that might not yet have been tried.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Peter_L







    Forum Moderator

    Have you used a diagnostic site such as:

    You might consider better hosting too.



    There seem to be a lot of things going on.

    Firstly, you were correct to try and use a caching plugin. Right now you don’t seem to have any caching at all. This means that every single thing on the page gets reloaded freshly, even though it’s available inside the browsers cache. You could indeed use W3 Total Cache plugin to solve this. Take your time to read through the settings.

    There also seems to be a lot of redirecting going on from to This can be easily fixed. Look through your code and just always use the www. version.

    You might indeed want to use sprites.

    I’m getting an error: Lines: 138, 182 Status: 406 Not Acceptable. Not sure what this is about.

    But the main problem seems to be lying with 2 files having a very slow response time:

    The latter looks like a very weird format to me. Double check this.
    The html/text of the home page itself (or the other pages) takes a huge time to load. Can’t directly see why.Could be wrong header connection. Not sure.

    What you could try. Create an empty test page. Make a more or less empty/static page template. Attach this template to empty test page. Check loading time of test page.

    Oh, and lastly, the site can’t find this file:



    I’d tried a page load testing site but not the one you recommended, YPyogi. GTMetrix has been really useful and I’ve used it to minify various CSS files, so thanks for that suggestion.

    Peter_L – thanks to you too. I asked my hosting company about the poor results that seemed to be coming from their end and they suggested adding lines to the .htaccess file for “leverage browser caching” and that seems to have helped with page load times.

    I couldn’t find anything within my WordPress settings where my site URL was shown without the “www” so I used the Search and Replace plugin and it changed a few instances for me.

    The woo-layout-css thing really has me stumped. It looks like it’s having a massive effect on load times, yet I’ve not been able to find anything within the theme files that corresponds with it. Clicking the link in GTMetrix just brings up about half a dozen lines of CSS. I tried Googling, but didn’t come up with an answer.

    The error you picked up in isn’t for me to worry about as that’s the junior team site, run by someone else.

    I have this problem too, as the woo-layout-css thing is the one slowing down my site, according to

    Did you fix that poorlittlefish? I don’t know what to do!

    Yes, I did solve the problem… by moving to a new hosting company. As soon as I did that my site started to load much faster and the 404 error hasn’t appeared once. Clearly the blame lay with the original hosting, though they claimed to have tried everything.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Slow loading frequent 404 errors from admin end – tried everything!’ is closed to new replies.