Support » Fixing WordPress » Slow, Failing WP Plugin & Theme Installations

  • Hi Everyone,

    I’m experiencing an issue similar to the one outlined here, but with a few key differences.

    Here’s the overview:

    cPanel 11.25.0-R46156 – WHM 11.25.0 – X 3.9
    CENTOS 5.5
    PHP 5.2.11
    MySQL 5.0.90
    Apache 2.0.63

    Freshly, manually installed WP3 with all directory permissions properly set and no pre-existing plugins or themes.

    When I attempt to install a theme or plugin (I’ll use auto-install for Foliopress WYSIWYG as an example), I enter my FTP info as prompted and get through to the following:

    Downloading install package from…
    Unpacking the package…
    Installing the plugin…

    If I look at my FTP logs as this process continues, I see output for all files which is well represented by the following snippet:

    Jun 23 13:37:02 host pure-ftpd: (bret@ [NOTICE] /home/bret//public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/images/smiley/msn/lightbulb.gif uploaded  (303 bytes, 1286.10KB/sec)
    Jun 23 13:37:02 host pure-ftpd: (bret@ [INFO] Can't change directory to /public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/images/smiley/msn/lightbulb.gif/: Not a directory
    Jun 23 13:37:03 host pure-ftpd: (bret@ [NOTICE] /home/bret//public_html/builtenv/wp-content/upgrade/foliopress-wysiwyg.tmp/foliopress-wysiwyg/fckeditor/editor/images/smiley/msn/omg_smile.gif downloaded  (342 bytes, 9037.63KB/sec)
    Jun 23 13:37:03 host pure-ftpd: (bret@ [NOTICE] /home/bret//public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/images/smiley/msn/omg_smile.gif uploaded  (342 bytes, 2285.21KB/sec)
    Jun 23 13:37:03 host pure-ftpd: (bret@ [INFO] Can't change directory to /public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/images/smiley/msn/omg_smile.gif/: Not a directory

    Eventually, the plugin installation fails:

    Could not copy file. /public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/lang/tr.js
    Plugin install failed.

    This failure is exemplified by the final FTP log output:

    Jun 23 13:39:23 host pure-ftpd: (bret@ [INFO] Can't change directory to /public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/lang/sv.js/: Not a directory
    Jun 23 13:39:28 host pure-ftpd: (bret@ [NOTICE] /home/bret//public_html/builtenv/wp-content/upgrade/foliopress-wysiwyg.tmp/foliopress-wysiwyg/fckeditor/editor/lang/th.js downloaded  (29906 bytes, 388872.94KB/sec)
    Jun 23 13:39:28 host pure-ftpd: (bret@ [NOTICE] /home/bret//public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/lang/th.js uploaded  (29906 bytes, 25371.78KB/sec)
    Jun 23 13:39:28 host pure-ftpd: (bret@ [INFO] Can't change directory to /public_html/builtenv/wp-content/plugins/foliopress-wysiwyg/fckeditor/editor/lang/th.js/: Not a directory

    Back at the plugins manager, there is no evidence of the installation. In the upgrade folder, however, I see ‘foliopress-wysiwyg.tmp’ and in the plugins folder I see a ‘foliopress-wysiwyg’ directory.

    The two big issues here:

    • Plugin and theme installation is incredibly slow.
    • Plugin and theme installation fails constantly. Maybe due to the constant trailing slashes we see in the FTP logs? What’s up with those slashes?

    Any ideas on this one?

Viewing 5 replies - 1 through 5 (of 5 total)
  • talkbret


    Any additional exposure on this issue? Thanks much!



    I am having the same problem with WP 3. Although I cannot access the FTP logs, I do experience the slowness when performing FTP related functions like installing plugins or themes. Sometimes the whole process fails altogether. The page will also time out.

    To monitor the installation I will go into the wp-content/upgrade/xxx.tmp/xxx/ folder and constantly refresh to see the files ‘disappearing’ as they are moved into place. The time it takes to finish the installation is rather proportionate to the size of the files, and the number of files to be moved, but the files are usually too small to even matter.

    WP 2.9.2 was fine.

    Solution: switch from Pure-FTPd to ProFTPd as the FTP service. Obviously you need access to the server to do this, or contact tech support for your host.

    I work for a great webhosting company ( that has a lot of customers using WordPress. Lately we’ve been seeing this issue a lot more and it was driving me nuts.

    This same problem happened about a year or so ago, and this bug report was made and a patched file was released to fix it:

    However, the modified class-ftp-sockets.php file did not work in this latest round of problems.

    From what I’m able to tell by looking at the logs during an upgrade or plugin installation, the script attempts to write to an invalid path (usually /public_html/somefile rather than /home/username/public_html/somefile) before using the correct path. It does this for each and every file, so during a major operation like an upgrade where a lot of files are involved it takes a very long time. Eventually the script freaks out and tries to access more memory than is allowed by our suhosin php security module. In most cases it attempts to access 256MB while our default limit is 32M. Suhosin blocks the script and the installation fails.

    While working on the dedicated server of a customer that was having this problem, I changed the FTP configuration to use ProFTPd in place of PureFTPd, and the upgrade worked immediately and without complication.

    Hopefully this will help someone, and hopefully WP can fix this bug!

    asoscott you were absolutely correct. We were dealing with this exact issue on cPanel servers with similar specs (php 5.3). Switched to ProFTPd and our WordPress issues went away.

    We have other non-cPanel servers (custom setups) that run vsftpd. They were so much faster and never had install/upgrade errors. Debugging plugins from wp-admin and watching the ftp messages come through was painful. Could not believe that it was a cPanel overhead issue. The only thing we could identify was a timeout and/or memory limit being reached that was set by cPanel. Never thought that it would be due to Pure-FTPd.

    Thanks, it was helpful (very)…

    Oh, and the upgrade was immediate and didn’t have complications for us either (second opinion).

    Thanks to everyone who worked to clarify this issue- I’ve got multiple clients with the problem. So is this in the trac? Will it be fixed by WordPress at any point? Trying to find info and failing.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Slow, Failing WP Plugin & Theme Installations’ is closed to new replies.