Support » Plugin: WP User Avatar » Slow down sites admin / backend extremly

  • Resolved Jonas Lundman

    (@jonas-lundman)


    Is it necessery to load all this on every backend page? The administration add a second more page load time just for the user avatar plugin.

    <script type='text/javascript' src='http://localhost/wp-new/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery,utils,farbtastic,underscore,backbone,media-models,plupload,plupload-html5,plupload-flash,plupload-silverlight,plupload-ht&load%5B%5D=ml4,json2,wp-plupload,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,media-views&ver=3.5.2'></script>
    <script type='text/javascript' src='http://localhost/wp-new/wp-content/plugins/media-library-assistant/js/mla-media-modal-scripts.min.js?ver=1.41'></script>
    <script type='text/javascript' src='http://localhost/wp-new/wp-content/plugins/wp-user-avatar/js/wp-user-avatar.js?ver=1.5.2'></script>

    Then a lot of inline code, css files are added too.

    Remark, loading some scripts activates other plugins scripts too. This is not strange I guess, the media manager are hooked with many other features.

    Why not use the plugin on profile edit screen, use if $pagenow = …

    We love this plugin and wanna use it! But clients complains on slow site since this are active.

    http://wordpress.org/extend/plugins/wp-user-avatar/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi Jonas, I’m still researching what will be the best way to approach this, but I am working on a solution for the next version of the plugin.

    I’ve made some improvements to the plugin in version 1.5.3. Please update and let me know if you see better performance. The media upload scripts should only load on profile pages and avatar admin pages now.

    Hi,
    I have now tested my current workspaces with this threads issue(s) and the performance is not a problem anymore!

    Nice work, thanks!

    Hi,

    I have your plugins last version, today I had to deactivate WP User Avatar, because it made the website very, very slow. Normally the web loads in approx. 1 second, with WP UA it loads in 13 seconds. Something wrong with that plugin, please make it work again 🙂

    Thanx

    @caesar19 – Have you tried just deactivating and reactivating the plugin? Sometimes it just needs that. If you need further assistance, please start a new thread as this one is closed. Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Slow down sites admin / backend extremly’ is closed to new replies.