Support » Plugin: Cooked - Recipe Plugin » Slow, custom permalink destroyed my positions on google

  • Resolved Cristiano

    (@cristiano)


    The plugin really is well done, has the best features that a recipe plugin needs, there is no similar product on the market.

    I’ve been a Cooked-pro user for a year and my visits have plummeted, it’s no use being nice and full of features if you do not have visitors.

    Without speed and without SEO we do not have visits, without visit we do not make money

    The big problem with this plugin is that it only works with the custom taxonomies / categories.

    And this makes it difficult to integrate with the vast majority of themes and plugins, including SEO plugins.

    The worse the plugin creates on your site two different kinds of permalinks (if you use blog and recipes) leaving google confusing and plummeting your visits.

    All other wordpress recipe plugin best placed on google work with the standard categories and posts of wordpress

    This plugin has lots of shotcodes, to be placed on custom pages, so it does not make much sense, it does not use the standard categories and posts of wordpress.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @cristiano Unless you are reporting spam or abuse please do not report topics.

    Plugin Author Boxy Studio

    (@boxystudio)

    @cristiano

    Unless I’m missing something, I created settings to avoid these issues. If you go to Settings > Recipes and scroll down near the bottom you will see some Advanced Settings.

    If you only want to embed the recipes into blog posts:
    Enable “Disable Public Recipes” — This will remove the permalinks to the custom post type recipes.

    If you want to only use the custom post type permalinks:
    Simply don’t embed recipes in your blog posts.

    If you’re running into issues with meta tags:
    Enable the “Disable Cooked <meta> Tags” to prevent Cooked from placing meta tags.

    If you run into issues with AMP:
    Enable the “Disable AMP Support”.

    Hello @boxystudio , thank you for the explanations, I’ll try these settings!

    I enjoy the opportunity it and left my review in the plugin. I wanted to give 10 stars but the maximum allowed is 5. Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.