WordPress.org

Support

Support » Installation » Slow blog and admin

Slow blog and admin

  • I recently implemented a wordpress theme that displays my blog on my own site (http://www.green-fab.com/blog). The problem is it loads sooooooo slow. Once it’s loaded, everything looks fine. I checked with my web host server several times and they can’t find any problems on their end. My blog only has one plug-in activated (Kimili Version 1.4 – flash embed). Does anyone have any recommendations on how to speed up the performance?

Viewing 2 replies - 1 through 2 (of 2 total)
  • That page has a total size of 1181 kilobytes. http://green-fab.com/wp-content/uploads/2008/03/corten-screens.jpg is 330Kb. smit3.jpg and greenfab.jpg are also big. The flash animation on top is 143Kb . Do you ask why it is slow?

    Also, as far as I can see Kimili’s swfobject.js, being in the html’s <head> section, forces the browser to load the flash player first before even beginning to render the page. Do those three scripts really have to be in the <head> section? Can you move them to the end of the HTML? Can you just embed the flash header on its own without need of a plugin?

    (Check it out yourself: Turn off javascript and load your page.)

    (By the way, you have two missing files: Inhabit.jpg and Silva%20Cell.jpg are still pointing your Windows Vista computer.)

    Come post again if you would like more tips.

    Have you tried with Firefox to see if it has same slowness? I am seeing it very slow using IE for some reason. Firefox seems way faster while surfing admin pages.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Slow blog and admin’ is closed to new replies.