Support » Plugin: Login No Captcha reCAPTCHA » Slow admin login when plugin is enabled

  • Resolved garywatson

    (@garywatson)


    We’re running the latest version (1.6.5) of your plugin and it works but, when it is enabled, login takes almost 3 minutes to complete. All other aspects of the site perform well so we don’t think it’s likely to be a site/server performance issue.

    The web server has outbound HTTP access disabled on the firewall (for security reasons) so I’m wondering whether perhaps this plugin attempts any outbound HTTP requests from the server side, e.g. reporting activity to Google?
    (this would be failing and we suppose the delay could be during an outbound request, e.g. until it times out)

    Thanks!
    Gary

Viewing 4 replies - 1 through 4 (of 4 total)
  • We see that there IS an outbound HTTPS request on the web server to 172.217.169.68 (a Google IP) during the delayed login, which suggests that the plug-in does indeed attempt to send an outbound request from the server side.

    Assuming you agree with this assessment, is there any way to disable the outbound request in the plug-in, to avoid the delay?

    Thanks again
    Gary

    Plugin Author Robert Peake

    (@robertpeake)

    Hi Gary,

    In order for the Google recaptcha to work, it must make an outbound server-side HTTP request to Google. This is the only way to verify the cryptographic signature in a secure way (i.e. done on the client side it could be spoofed). More details are here: https://developers.google.com/recaptcha/docs/verify

    So, if you have disabled all outbound requests, the very slow times are probably a network timeout. No (secure) captcha will work without outbound server-side requests.

    Good luck!

    Best,
    Robert

    Hi Robert, thanks for the quick response, all understood and thanks again

    Plugin Author Robert Peake

    (@robertpeake)

    Sure thing. The plugin tries to accomodate all forms of outbound https requests, so as long as it’s permitted at the php level and not blocked at the firewall level it should work. Good luck!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Slow admin login when plugin is enabled’ is closed to new replies.