Support » Plugin: Slimstat Analytics » Slimstat not tracking subscribers

  • Resolved treetex

    (@treetex)


    Hi
    First of all I just want to say it’s good to see u back Jason!

    My topic:
    I can’t see my subscribers activity in the activity log after they have logged in, it stops there.

    * Track WP Users is on.
    * I have cleared WP Super Cache and even tried to turn it off.
    * If i change a users role to contributor i can see all the users stats.
    * Did a fresh reinstall of Slimstat a week ago, it didn’t work before either.
    * Plugin Profile Builder is activated and subscribers log in on the frontend.

    A similar topic was published 2018 but was never resolved: https://wordpress.org/support/topic/problem-with-displaying-logged-in-users/

    Best
    Jack

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Hi,

    first of all thank you for your welcome back note! Much appreciated. Are these regular WP users, or just like in the other ticket, are managed through a separate plugin/subscription system? Also, are you filtering users by capability under Slimstat > Settings > Filters?

    Best,
    Jason

    Thread Starter treetex

    (@treetex)

    Hi,
    Yes, they are regular WP users and I was not filtering them in any way but…
    I made a local copy of my site and discovered that it was a script in functions.php that was disable admin bar and redirected them back to startpage that was causing this.

    I was able to modify the script and now I can see all stats for my subscribers. Sorry to have troubled you with this Jason. Slimstat Analytics is my number one plugin.

    Best,
    Jack

    Plugin Author Jason Crouse

    (@coolmann)

    Ha! Good to know that you were able to track down the issue. Please consider writing a review for Slimstat as a token of appreciation for the support you received. It would be a nice way to say thank you and to let people know how much you value this plugin:

    https://wordpress.org/support/plugin/wp-slimstat/reviews/#new-post

    Best,
    Jason

    Thread Starter treetex

    (@treetex)

    I have already done that! 🙂

    Thx Jason

    Plugin Author Jason Crouse

    (@coolmann)

    Much appreciated!

    Take care,
    Jason

    For the record, I switched to WP Fastest Cache since Super Cache does not work with SlimStat (IF) you use Cloudflare as well. I’ve tried Slim settings server vs client and both only show Cloudflare IPs with not the actual IP location.

    Just a heads up 🙂 HTH

    Plugin Author Jason Crouse

    (@coolmann)

    @thescarletfire that’s a completely different issues. We have an add-on to fix this problem with Cloudflare:

    https://www.wp-slimstat.com/downloads/firewall-fix/

    Best,
    Jason

    Oh wow interesting. I never knew that existed! That is front page news worthy 🙂 You guys are awesome. Worth the ten bucks for sure.

    Thanks.

    Plugin Author Jason Crouse

    (@coolmann)

    @thescarletfire thank you! We try our best, my friend!

    Jason

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Slimstat not tracking subscribers’ is closed to new replies.