Support » Plugin: Slimstat Analytics » Slimstat Multisite Setup Problems

  • Resolved johnw_wp

    (@johnw_wp)


    Is there any information on how to configure / install slimstats to work in a multisite environment.
    I find that it is only tracking stats on the parent site and not the subsite.
    If I go into the admin on the subsite, the links and Go button redirect me back to the parent (root) site.

    I installed the plugin in the Network Admin and then enabled the slimstat settings within each subsite.

    Thanks

    John

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Hi there,

    as the requirements state, “it may not work on multisite environments” 😉 It’s a WordPress design issue that core developers are not willing to fix at the moment. You may want to try to use a plugin called Proper Network Activation, which may solve the problem. I haven’t tested it, though, but other users reported that it worked with WP SlimStat on a multisite installation.

    Camu

    Plugin Author Jason Crouse

    (@coolmann)

    Just FYI, here is the track ticket where we discussed how WordPress should support network activations for plugins that need their own tables. Clearly core developers are not willing to implement something that solves the problem 🙁

    Thanks for the quick response. I will give the plugin a go. A pity as the plugin is great !

    Thanks

    John

    Plugin Author Jason Crouse

    (@coolmann)

    Please note that you can still activate WP SlimStat on a per-blog basis. It’s the network activation that does not work, not the plugin 😉 This may change in future releases, I may decide to (re)introduce some wpmu support. But I must admit that for its own nature, my plugin cannot scale well on large networks, and timeouts during activation may occur depending on the number of blog in the network. Up to 50-ish blogs there shouldn’t be any problems, though.

    A vote and/or a small donation for my plugin would be a nice way to thank me 🙂

    Best,
    Camu

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Slimstat Multisite Setup Problems’ is closed to new replies.