• Resolved djmceltic

    (@djmceltic)


    Hi

    We have the latest version of all slimstat plugins – we are a paying customer. It is a https site and we have a lot of hits saved by it – so it has created a few archive tables.

    We last updated slimstat 10 days ago to last version and have been on WP 4.6.1 for almost 3 weeks. Really no changes made to server in the past few weeks.

    Today users were complaining that the site was down and it was. Completely blank – every page including admin pages – no html processed. As soon as I manually deleted the slimstat plugin the site went back up. I have also went back to default theme and no plugins enabled and tried to enable slimstat. Again everything blank. So definitely a slimstat issue.

    The other weird thing going on is I also have slimstat installed on our dev site on the same server (different directory). Same exact versions. Works fine. The only difference between the installs is the usage and the dev site has no archive tables.

    What are my next troubleshooting steps because I am completely lost to what we should do?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Hi,

    sorry to hear about this issue. Have you checked your web server error log, as I suspect this might be a PHP memory limit issue. We are working on this issue by introducing a lightweight version of the Browscap database ( http://browscap.org/ ) which we use to determine your visitor’s browser and operating system. In the meanwhile, you can manually delete the file browscap-db.php in /wp-content/uploads/wp-slimstat (or /wp-content/plugins/wp-slimstat/browscap/ if you’re running Slimstat 4.4.2). That should solve the problem, at least temporarily. When Slimstat shows the nag message about installing Browscap, just X it out, and it will use the heuristic function to identify your visitors’ information instead. Please note that the heuristic function is not as accurate as Browscap though.

    Please let me know if that solves the problem.

    Jason

    Thread Starter djmceltic

    (@djmceltic)

    Hi Jason

    I will try this out tonight. I don’t understand because we have plenty of memory on the server. And it doesn’t work right after stop starting the server. If I need to up the php memory I can do that too. I still am not getting this issue because it just “happened” – site was working then boom nothing. The only thing that could really cause that is a mysql (maybe memory) issue right?

    Plugin Author Jason Crouse

    (@coolmann)

    Hi,

    the first thing I would do is to delete that file and see if that makes any difference. If it does, then it is most probably a PHP memory issue. Please note: you can have plenty of memory on the server, but that doesn’t necessarily mean that PHP is allowed to use all (or most) of it. You should ask your server administrator to let you know how much memory PHP can allocate, as defined in your php.ini.

    I doubt this is a problem with MySQL, as our table structure is highly optimized and unless you have millions of records in your database, it will not impact your entire site. It might slow down the report pages, in which case you can tweak the max records parameter in the settings, to use a smaller dataset to calculate all the metrics.

    If it turns out to be a PHP memory issue and you cannot increase that limit, you can always uninstall the Browscap data file (Slimstat > Settings > Maintenance) and let Slimstat use the (less accurate) heuristic function to determine your visitors’ browser names and operating systems. That’s exactly the reason why we implemented it this way: to give everybody a chance to use our software, even when they have server restrictions that don’t allow them to use it to its fullest.

    I hope this helps,
    Jason.

    • This reply was modified 7 years, 9 months ago by Jason Crouse.
    Thread Starter djmceltic

    (@djmceltic)

    Just to let you know, deleting the browscap file does not work, as it reuploads it as soon as it can’t find it.

    I went into the browsecap folder in the plugin and renamed one of the files so it failed. After it failed I turned off browsecap. This is basically failing on everything that we have now… so it is a pretty big issue when a plugin takes down your site.

    Plugin Author Jason Crouse

    (@coolmann)

    @djmceltic I understand your frustration. The ‘auto reupload’ of browscap was a bug that we fixed in version 4.4.5, could you please update Slimstat and try to delete that file again? If that still doesn’t work, please contact us at http://support.wp-slimstat.com and send us your configuration string ( Slimstat > Settings > Maintenance ) so that we can see if there’s anything there that is causing the re-upload.

    Best,
    Jason

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Slimstat making the site BLANK’ is closed to new replies.