Support » Plugin: Slimstat Analytics » Slimstat is slow on a brand new website

  • After installing the slimstat plugin and enabling no options, no maxmind, no browsercap in the settings, only just activating the slimstat plugin, I noticed my score on Google’s Page Speed Insights was reduced from 100 to 96!!!

    I have only 5 other plugins installed and with all 5 the score was 100. As soon as I installed and activated Slimstat score dropped from 100 to 96. My wordpress uses the latest php too.

    I suggest the developer to check himself, create a simple brand new website and check the scores, without even enabling anything in the settings.

    https://developers.google.com/speed/pagespeed/insights/

    Below are the reasons why slimstat is slow:

    Reduce the impact of third-party code Third-party code blocked the main thread for 1,920 ms
    Third-party code can significantly impact load performance. Limit the number of redundant third-party providers and try to load third-party code after your page has primarily finished loading. Learn more.
    Third-Party
    Size
    Main-Thread Blocking Time
    JSDelivr CDN
    13 KB
    1,922 ms
    Reduce JavaScript execution time 2.0 s
    Consider reducing the time spent parsing, compiling, and executing JS. You may find delivering smaller JS payloads helps with this. Learn more.
    URL
    Total CPU Time
    Script Evaluation
    Script Parse
    …4.8.8.1/wp-slimstat.min.js(cdn.jsdelivr.net)
    2,225 ms
    1,988 ms
    4 ms
    Other
    355 ms
    18 ms
    3 ms

Viewing 15 replies - 1 through 15 (of 17 total)
  • I have come here to report just the same observation. My site is slowed down by almost 3s! Pagespeed score going down to 42 from 88 (mobile). Slimstat is not really usable like that.

    Can you anyone provide some more information?
    For example the HTTP headers of the slow request for that file.
    Also your location would be helpful as well.

    Plugin Author Jason Crouse

    (@coolmann)

    Hi guys,

    I wonder if this is related to the new fingerprinting feature that we recently introduced in Slimstat. Would you be available to run a few tests for me with a modified tracker that I could send you? If so, please contact me at https://support.wp-slimstat.com

    Thank you,
    Jason

    @jimaek It’s not the request, it’s the processing, i.e. the js takes a long time to run.
    (see bluebit’s log: Script Parse)

    @coolmann I’ll contact you

    Plugin Author Jason Crouse

    (@coolmann)

    By the way, on our clean vanilla install with Slimstat enabled, we get better results:

    https://developers.google.com/speed/pagespeed/insights/?url=http%3A%2F%2Fdev.wp-slimstat.com%2F&tab=desktop

    Have you tried deactivating the CDN option under Settings > Tracker to see if things improve?

    Best,
    Jason

    deactivating the CDN doesn’t help, it just increases javascript execution time, see below:

    Reduce JavaScript execution time 3.1 s
    Consider reducing the time spent parsing, compiling, and executing JS. You may find delivering smaller JS payloads helps with this. Learn more.
    URL
    Total CPU Time
    Script Evaluation
    Script Parse
    …wp-slimstat/wp-slimstat.min.js
    3,434 ms
    2,896 ms
    4 ms

    • This reply was modified 1 year, 1 month ago by bluebit.
    Plugin Author Jason Crouse

    (@coolmann)

    Fair enough. I’m still convinced it’s the fingerprinting algorithm. Would you like to help me test the difference between a script with and one without that feature?

    Jason

    bluebit

    (@bluebit)

    sure, ill be happy to test

    • This reply was modified 1 year ago by bluebit.
    Plugin Author Jason Crouse

    (@coolmann)

    Ok, please contact me at https://support.wp-slimstat.com and I’ll send you the instructions.

    Jason

    richardlowejr

    (@richardlowejr)

    I’m having exactly the same issue. Love to hear the results of your testing.

    pollensteyn

    (@pollensteyn)

    It’s mentioned before in another thread but the plugin also takes a hit on admin-ajax.php, By design of course, but the difference between using slimstat and not using it is ~ 2 seconds in page loading time in my case, even before the new fingerprinting algorithm functionality was deployed. I guess every analytics tool is a burden on page loading performance, and maybe what you see here is the difference between *measured* page speed and *perceived* page speed. I’m quite picky when it comes to page speed performance and I don’t think it’s worth my wile seeing all of my hours of tweaking getting undone by using a statistics plugin.

    Best wishes
    Paula

    any news on this topic?

    Any update on this?

    I have deactivated slimstat for a while now because of this as I have mentioned on this thread. https://wordpress.org/support/topic/slow-load-time-15/page/2/#post-12306996

    Is this plugin supported anymore?

    @richardlowejr good question. I am not sure but in the past there was a very long period of time that the developer was not well. All of us was stuck without any words. Now it seems like about 2 months no word.

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.