WordPress.org

Support

Support » Plugins and Hacks » Slim Stat Analytics » [Resolved] Slimstat 2.9.4 not working with W3 Total Cache (JS Mode)

[Resolved] Slimstat 2.9.4 not working with W3 Total Cache (JS Mode)

  • I upgraded from 2.9.3 to 2.9.4 and the plugin was no longer tracking new data.

    I have W3 Total Cache installed and I tried clearing the cache after upgrade and it still did not work.

    I have JS minify enabled on CloudFlare and I’m not sure if anything in the Slimstat JS code changed. (CloudFlare JS minify worked fine with version 2.9.3)

    I went ahead and uninstalled 2.9.4 and I guess this also deleted all stats stored in the database? It’s ok because I didn’t have many stats tracked. Maybe you can improve the process so uninstalling the plugin keeps the data stored in the database. I just installed this plugin 1 month ago so I am fairly new and I don’t really know how the slimstat uninstall process works.

    I then installed version 2.9.3 from the WordPress server.

    After changing the settings to what I had them on before (JS mode is on), stats were now being tracked like they should be.

    There must be something in 2.9.4 that is making it not track stats for me.

    I’m not sure what changed in 2.9.4 because 2.9.3 worked perfectly.

    Also: I’m not sure if this is a Slimstat bug or an iOS bug, but Slimstat is tracking visits from Safari in iOS 6.1 as “Mac OS X”.
    Using the Chrome browser app in iOS 6.1 tracks correctly as “iOS”.

    http://wordpress.org/extend/plugins/wp-slimstat/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Jason Crouse

    @coolmann

    Hi there,

    the JS code in 2.9.4 is different, and I am honestly having a hard time understanding what the problem is, since you are not upgrading all the pieces consistently 😉 You cannot expect to have a piece of 2.9.3 to work flawlessly with a piece of 2.9.4.

    About the data deletion, you’re asked TWICE if you are sure, and WARNED that all the data will be deleted, so if yuu still go ahead and proceed, then there’s nothing that I can do about it. I cannot leave a ‘dirty’ environment when the plugin is uninstalled, that is against WordPress’ guidelines.

    As for the detection issue, unfortunately the database SlimStat relies upon ( browscap.ini ) hasn’t been updated in a while, so the heuristic detection is triggered. Hopefully they will release a new update soon. You may want to ask them if there’s a timeline set for that already.

    Cheers,
    Camu

    I don’t think you fully understand my problem.

    What do you mean by I am not upgrading the pieces consistently?

    Data tracking no longer worked for me after upgrading from 2.9.3 to 2.9.4 so I did a full uninstall and installed 2.9.3 (THE PREVIOUS VERSION) because it was working for me.

    I’m not sure what changed in 2.9.4 for it to stop tracking data.

    What is different in the JS code in 2.9.4 that causes the tracking to stop?
    (This was not announced in the change log)

    So right now I have 2.9.3 installed and I have no problems with tracking.

    About the data deletion: Yes I understand, but for times like this when tracking doesn’t work, I had to reinstall an older version for tracking to work, which resulted in data being deleted.

    About this iOS issue:
    I found this bug report and the problem has been reported: http://drupal.org/node/1907886

    And there is a discussion here:
    https://groups.google.com/d/topic/browscap/GSgqVdYRt7g/discussion

    Supposedly there is a fix if you add this line to the Mobile Safari 6.0 section, but the plugin uses a cache file that implements this different it seems so I can’t quite figure out how to add the line without messing anything up.

    [Mozilla/5.0 (iPhone*CPU*OS 6_1* like Mac OS X*)*AppleWebKit/*(*KHTML, like Gecko*)*Version/6.0*Mobile/*Safari/*]Parent=Mobile Safari 6.0

    I’m having the same problem I’ll have to go back to the previous version (2.9.3)

    Any ideas as to why it broke in the new version?

    This is happening to multiple people. Please don’t ignore this problem.

    Plugin Author Jason Crouse

    @coolmann

    Post the URL where this is happening. Is it

    http://www.mattsuda.com/main/

    If that’s the URL, please upgrade to 2.9.4 again so that I can see what’s going on.

    Best,
    Camu

    Home

    Currently running 2.9.3

    Upgrading now 1 sec

    Alright, upgraded to 2.9.4

    Home

    Plugin Author Jason Crouse

    @coolmann

    Okay, I see what the problem is. You’re using the CDN, but unfortunately the javascript hasn’t still fully propagated, so disabling that option for a few days, should fix the issue.

    Please keep us posted.

    I’ll get back soon

    Plugin Author Jason Crouse

    @coolmann

    And if it works, a vote for my plugin would be a nice way to say thank you 😉

    As for the iOS detection, this will be hopefully fixed in version 3.0.

    Cheers,
    Camu

    Thanks it works now!

    I would suggest putting a note by the feature letting users know that when the plugin updates, the CDN takes time to update.

    Since I use CloudFlare, I guess I don’t need to use the CDN option because my site is already somewhat optimized.

    Thanks for planning to fix the iOS detection! =)

    I really like your plugin!

    Plugin Author Jason Crouse

    @coolmann

    Thank you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Slimstat 2.9.4 not working with W3 Total Cache (JS Mode)’ is closed to new replies.
Skip to toolbar