WordPress.org

Support

Support » Plugins and Hacks » Slideshow » [Resolved] slideshows disappeared after installing 2.2.8

[Resolved] slideshows disappeared after installing 2.2.8

Viewing 3 replies - 1 through 3 (of 3 total)
  • There seems to be an issue with it not being able to determine object length.

    TypeError: ‘undefined’ is not an object (evaluating ‘j.length’).

    http://kerithorpe.com/photography-2/

    I removed the code below from my theme’s functions.php file which fixed the problem. Slideshows no appear. The script was part of a Blank theme I downloaded from a WordPress course.

    wp_register_script(‘jquery’,
    (“http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js”), false);

    I’m a little embarrassed to say I don’t know what the script does. So far, my website doesn’t seem to miss it. I think WordPress updates have made it obsolete? Hope so.

    It was part of a larger code entry:

    // Load jQuery
    if ( !is_admin() ) {
    wp_deregister_script(‘jquery’);
    wp_register_script(‘jquery’,
    (“http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js”), false);
    wp_enqueue_script(‘jquery’);
    }

    Plugin Author Stefan Boonstra

    @stefanboonstra

    I’m glad you were able to find the problem. The older jQuery library, which your website loaded previously, didn’t support some of the functionalities required by the slideshow.

    However, I have been able to fix the problem with the older jQuery version. It may still be of some use to others.

    You can always download an older version from the ‘Developers’ tab.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] slideshows disappeared after installing 2.2.8’ is closed to new replies.
Skip to toolbar