WordPress.org

Support

Support » Plugins and Hacks » [Resolved] slideshow not working at all in WP 3.5

[Resolved] slideshow not working at all in WP 3.5

Viewing 15 replies - 1 through 15 (of 33 total)
  • Plugin Author Josh Leuze
    Participant

    @jleuze

    Hi, this isn’t a WordPress 3.5 issue, Meteor Slides should work fine with the latest version of WP. It sounds like you have a JavaScript problem, due to a theme or plugin conflict, can you post a link to the site you’re working on?

    i am running a local version so no website link to send you to. i am in the process of creating a custom theme based on twentytwelve and i have not added any javascript to it, just html and css so far… i’ll double check the pages i made to see, any idea where the JS problem would stem from?

    I posted this as well in another topic and am still awaiting a response.

    I thought of a JS problem as well but as Raproo stated I have made no major changes to the site. Meteor just stopped working.

    Josh, I know you’re busy but some kind of direction would be greatly appreciated.

    Many thanks.

    http://price-comparison-site.com

    Never mind Josh. Got it.

    It was the BP Template Pack JS / AJAX causing the issue.

    Works fine now.

    Plugin Author Josh Leuze
    Participant

    @jleuze

    @raproo Ah, did you build your theme from scratch? It sounds like none of the scripts for Meteor Slides are loading, did you include the wp_head function in the head of your header.php file?

    @jleuze yes, still building from scratch actually. no i did not add that function to the head. i just did and now the images are showing a nice slideshow as intended, however when i roll over with the mouse they are jumping down the page to expose the next & previous buttons… home.php currently looks like this:

    <head>
    	<?php get_header();?>
    	<?php wp_head();?>
    </head>
    
    <body>
    
    	<div id="headerSlideshow">
    		<?php if ( function_exists( 'meteor_slideshow' ) ) { meteor_slideshow(); } ?>
    
    	</div>
    Plugin Author Josh Leuze
    Participant

    @jleuze

    With some themes the nav needs to be inline instead of block, try adding this in your theme:

    .meteor-slides.navhover ul.meteor-nav {
    	display: inline !important;
    }

    that did the trick. thank you very much for all your help!

    Plugin Author Josh Leuze
    Participant

    @jleuze

    You’re welcome!

    Hello!
    I am having a similar issue, used to work then stopped working when I updated to Worpress 3.5.
    My test page is:
    http://www.stylehaus.com/image-test/

    Can you help me with this? I am getting a JS error when I view with developer tool on Chrome, but not sure how to fix this.
    Thank you!!

    Hello!
    I am having a similar issue, used to work then stopped working when I updated to Worpress 3.5.
    My test page is:
    http://www.stylehaus.com/image-test/

    Can you help me with this? I am getting a JS error when I view with developer tool on Chrome, but not sure how to fix this.
    Thank you!!

    Plugin Author Josh Leuze
    Participant

    @jleuze

    This is a conflict with your theme, maybe the jQuery in your theme has some bugs that are coming up with jQuery 1.8.3.

    The first error is coming from a theme file, fastblog.js:

    Uncaught Error: Syntax error, unrecognized expression: h9,h3,h2,

    I don’t see a reference to “h9” tags in the script, but maybe check the theme settings or something, it will have problems targeting h9 tags since those don’t exist.

    The second error is from page.js, which doesn’t seem to be part of the theme, maybe it is being added by a plugin, or maybe in the header.php of your theme.

    First thing I would do is deactivate your other plugins and confirm that none of them is causing this problem, like the page.js error, try to narrow down where that is coming from.

    Second, in your theme I would try temporarily disabling page.js in the header or functions file and test it to see if the slideshow works when that script isn’t running.

    dipovespo
    Member

    @dipovespo

    Thanks, I just know that I must use <?php wp_head();?>
    Have a same problem, now solved.

    But why the height is so tall?
    it use the height: 100% !important; for div.meteor-slides

    not the height of the element style.

    I work on localhost, too bad can’t give a link.

    Plugin Author Josh Leuze
    Participant

    @jleuze

    @dipovespo Sorry, I couldn’t say for sure without seeing the site. The 100% is to get the slideshow to scale responsively, it shouldn’t cause the height to go beyond the max size of the slideshow, but you could try changing the height to auto.

    Hey Josh. I updated to WP 3.5 and the meteor-slidshow in the home page doesn’t show. The url is:

    http://www.bcninteriorismo.com/

    The slideshow place is at the beginning of the main content, after the first pale yellow box. I’ve checked with Firebug in Firefox and with Chrome Developer and didn’t find any JS error. I also have deleted the JQuery files inserted from my theme and it seems that it only loads the JQuery from WP, the 1.8.3 at this moment. I’ve tried to disable the other plugins but the error persists and tried with Thesis 1.8.5 and it doesn’t work either.

    Thanks for trying to help. Happy New Year 2013.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] slideshow not working at all in WP 3.5’ is closed to new replies.