Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Slideshow not working

  • Hi,
    Have been trying to use the NexGen Gallery but can’t seem to get it to work. Anytime I load the page ( the slideshow looks like it is loading, but then the pics never appear. I think the swf file is in the right place and everything is updated to the most recent version. Any thoughts on how to fix this?

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’m having the same problem. When I try and use the slideshow, it just shows a spinning circle and never actually loads. I’m using Firefox 3.6.18, WordPress 3.2.1, Theme Pilcrow, Nextgen 1.8.2, JW Rotator.

    I thought my images sizes might be too big but tried with just two smaller images and still have a problem.

    Do I need a special version of Adobe Flash?

    I got the slideshow to display by checking enable flash slideshow. I need to play with the other settings to get rid of black space but it works!
    @langsider I like your site, good content.

    Thanks @ackeaney! Problem solved.

    I have a similar problem. It was working ok up until about a month ago but has since stopped. I have been carrying out the updates as they have become available for wp and other plugins. I’m really not sure what is wrong.

    The gallery thumbnails works ok. I can load the image rotator swf file by itself so the path to that is ok.

    i have the slideshow enabled in the options.

    when i look at the output in the page on the front end i see this where the slideshow should be

    <!– error: provide id, w, h –>

    Same problem. The NG Slideshow widget simply shows the spinner, no images.

    For the JW imagerotator I’ve done the following:

    Uploaded imagerotator.swf to both uploads/ and plugins/nextgen-gallery/.
    On Gallery/Options/Slideshow tab:
    1. “Search now” auto-located uploads/imagerotator.swf
    2. Checked “enable flash slideshow”
    3. Enabled navigation bar
    4. Saved changes

    With flash enabled, NG Slideshow widget now shows a black box with spinner. Again, images never display.

    Something that may be related – I’ve installed the NGG Video Extend plugin. When I add its shortcode to an image description per the installation instructions, when I click on the image thumbnail, the lightbox pops up and says “loading…” The movie never plays.

    Also tried the NGG monoslideshow plugin. Installed and activated. But when I added

    [monoslideshow id=3 w=450 h=350]

    (id 3 is a valid gallery ID) to a post, nothing displayed.

    Looks like a flash configuration issue?

    Have you tried deactivating the plugins, getting the most recent version of Flash.
    Then activating just NG Gallery and SW Rotator to see if some other plugin is interfering with your set-up. Also just use Nextgen with vanilla settings.
    What browser are you using? Sometimes things don’t work in IE but do in Firefox etc.

    I’m running Firefox 5.0 on Ubuntu 11.04.

    1. Deactivated all plugins.
    2. Upgraded to latest flash, now 11,0,1,60 installed
    3. Reactivated Nextgen Gallery; added NG slideshow widget to sidebar.
    4. Started Firefox, went to site.

    Result: no difference. Flash works for me everywhere else (Youtube, etc.), just not here.

    Have you increased the memory in
    How about checking permissions on the server, all files used by imagerotator should be 755 ( I think)?

    I’m assuming you’re referring to this line in

    // increase memory-limit if possible, GD needs this for large images
    // @ini_set('memory_limit', '128M');

    I’ve uncommented the line and set it to 64mb, which is the limit my ISP allows for PHP. However, thumbnail generation is working in NGG (except for a few very large images). The gallery I’m attempting to do a slideshow of only has nine images, all 1500×1800, none larger than 470k.

    Increasing the above memory limit to 64mb didn’t work.

    all files used by imagerotator

    Unfortunately, I don’t know what files are used by imagerotator, aside from the images themselves. The directory of the image gallery I’m trying to use and its thumbs dir are both 755; the images and their thumbs are 644. imagerotator.swf is also 644.

    @nathanaelculver: all files used by imagerotator
    I meant all the photos are accessible. What w= h= parameters are being used for the display, could it be something with that?
    Can you use Firebug or ViewSource to see the code used at that point and see if that helps?
    I’m a newbie signed up for PHP programming in the Fall so sorry cannot share anymore knowledge.
    I find it frustrating that the forum is not more helpful and that people don’t post resolutions to problems. Good luck.


    Same problem here. Spinning wheel with or without Flash enabled, worked fine until last upgrade.


    Yes, I am also having the same issue.

    The loading spinning wheel is appearing for the normal slideshow option but the flash slideshow option is working. All other ‘gallery’ options are also working and show the images.

    Would really like to get this to work with the normal jQuery slideshow.

    Did anyone find a solution to this?

    I also have the same problem.

    Would really appreciate a fix / solution for this….

    anyone out there know?!?



    I got the same problem.

    I hope for a solution….

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Slideshow not working’ is closed to new replies.