Support » Plugin: WP Photo Album Plus » Slideshow not working

  • Resolved xifilk

    (@xifilk)


    I’ve tried the WPAA+ Slideshow widget.
    I tried [wppa type=”slideonly” album=”1″][/wppa] but nothing works.
    The only thing I’m getting is a black page with no slideshow to be seen.

    What am I doing wrong?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Can you supply a link to the page, please?

    https://testsite.anthonyfotoclub.be/test/

    There should be a slideshow on that page.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    There is a rights problem:

    You don't have permission to access /wp-content/uploads/wppa/temp/wppa.45U4zJMgH9ln.js on this server.

    and:

    /wp-content/uploads/wppa/27.jpg is not found

    If you have any kind of caching and/or security plugin, de-activate them until you finished setting up your site.

    Make sure the filesystem rights ( chmod ) on …/wp-content/ and all folders below it is at lease 0755

    Also, make sure there is no access limiting in a .htaccess file that denies access to things inside wp-content

    Just contacted the support where I host the website.

    They told me the following:

    The reason is the .htaccess file added to the uploads folder by us. This prevents script execution from the uploads folder, to limit hackers ability to upload and access malware they upload, that land in that folder.

    I would recommend getting that script placed in a different folder than in a subfolder to /wp-content/uploads/ if possible.
    If not, change
    RewriteCond %{REQUEST_URI} !^.*wp-content/uploads/visualcomposer-assets/.*\.js$
    to:
    RewriteCond %{REQUEST_URI} !^.*wp-content/uploads/(visualcomposer-assets|wppa)/.*\.js$
    inside:
    /testsite/wp-content/uploads/.htaccess

    I modified the .htacces file as they suggested and that solved the problem.

    Thanks for the quick help!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Slideshow not working’ is closed to new replies.