Support » Plugin: Slideshow » Slideshow not working

  • Resolved brubens

    (@brubens)


    Hi,
    I’m new to wordpress. Created a simple custom theme and added slideshow (latest version).
    Result: i’m getting all my images on the webpage, one be need the other. I asked not to show the scroll buttons, but they appear.

    When I copy the slideshow code into the Twenty Twelve theme, it works.

    What is missing in my custom theme? Where do I have to look ?

    Regards,

    Bart.

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

Viewing 11 replies - 1 through 11 (of 11 total)
  • Check the generated source code of the page. jquery could be loaded twice.

    Plugin Author Stefan Boonstra

    (@stefanboonstra)

    Hi Bart,

    As Gstricklind said, jQuery could indeed be loaded twice (thanks for thinking along).

    Another cause of the problem could be that your theme may be missing the call to the ‘<?php wp_footer(); ?>‘ function. This function call always needs to be right above the ‘</body>‘ tag in your theme’s ‘footer.php’ file. Without it, the slideshow’s script isn’t loaded. More information on ‘wp_footer()here.

    Best regards,
    Stefan

    Hi Stefan, Gstricklind,

    wp_footer is used, don’t find the jQuery twice.

    Here is the code:
    [Large excerpt of code moderated, please use PasteBin to handle your code instead]

    Plugin Author Stefan Boonstra

    (@stefanboonstra)

    Hi Bart,

    WordPress suggests you use PasteBin to show large blocks of code and has removed your code. Perhaps you can give me the address to your website so I can have a look and see what’s wrong.

    Best regards,
    Stefan

    Hi
    I have put the slideshow (of which there are 7 images) on my home page http://www.top10fragrances.com The problem is that it is only showing the first image and not scrolling through the other 6. What am I doing wrong? Also underneath each image there is a space to put a URL & description what is that for?
    Thanks in advance.
    Vanessa

    Plugin Author Stefan Boonstra

    (@stefanboonstra)

    Hi Vanessa,

    Your theme’s ‘style.css’ contains a setting that sets all ‘div‘ elements to a maximum width of 100%, which breaks the slideshow.

    To solve the problem, find your theme’s ‘style.css’ file and look for line 331, where you’ll find this block:

    pre,
    .hfeed div, /* Remove this line to solve the problem. */
    input,
    textarea{
    	max-width:100%;
    }

    Remove the indicated line and your slideshow should work.

    Best regards,
    Stefan

    Plugin Author Stefan Boonstra

    (@stefanboonstra)

    Hi (again) Vanessa,

    I seem to have forgotten your second question. The URL field is for linking to websites, either yours or someone else’s. The text you write in a description field will be placed below the title in the description box of that slide.

    Best regards,
    Stefan

    Hi Stefan,

    here’s the link

    http://rubens.homedns.org:8888/thehealinghorse.be

    Regards,

    Bart.

    Plugin Author Stefan Boonstra

    (@stefanboonstra)

    Hi Bart,

    Thanks for the address (although the page isn’t styled because of the URLs pointing to localhost instead of the webaddress).

    You said the ‘<?php wp_footer(); ?>‘ function is called in your theme, but there are no scripts or styles loaded at the bottom of your page. The slideshow’s script misses here as well. Where exactly do you call the ‘<?php wp_footer(); ?>‘ function and in what file do you do this?

    Best regards,
    Stefan

    Hi Stefan,

    I found the error. There was a misunderstanding with wp_footer()!

    I had a get_footer() in the index.php and in the footer.php, I had no wp_footer().
    I added the wp_footer() and now everything works fine.

    Thanks for you’re help.

    Regards,

    Bart.

    Plugin Author Stefan Boonstra

    (@stefanboonstra)

    Hi Bart,

    Great, you’re welcome!

    Best regards,
    Stefan

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Slideshow not working’ is closed to new replies.