WordPress.org

Forums

HG Slider
[resolved] Slideshow not appearing on homepage (15 posts)

  1. orangjul
    Member
    Posted 2 years ago #

    Hi, I followed your instructions exactly, and I cannot get the slideshow to appear anywhere. On my homepage, I tried calling the function you had us add to functions.php, but it doesn't render any code on the page. What am I missing? I have some minimal PHP knowledge but I need a bit more explanation please.

    http://wordpress.org/extend/plugins/flexslider-hg/

  2. Hal Gatewood
    Member
    Plugin Author

    Posted 2 years ago #

    It will only render code on the page if you have added Slides in the admin and assigned them to that homepage.

  3. babouz44
    Member
    Posted 2 years ago #

    It seems to doesn't work... I also followed your instruction and I have 3 slides in back office but no slide...

    I put all your code in functions.php and this in header.php :

    <?php if(function_exists('show_flexslider_rotator')) echo show_flexslider_rotator( 'homepage' ); ?>

  4. Hal Gatewood
    Member
    Plugin Author

    Posted 2 years ago #

    Do you have WordPress debugging turned on? Do you get any error messages? What versions of WordPress are you using?

    Any additional information would be great as I don't have a lot of information to work with.

  5. Netzialist
    Member
    Posted 2 years ago #

    Hal,

    I've got the same problem, I think.
    I installed the plugin and setup the filter in functions.php. When trying to create a slide, there is this little, red message that says:
    "No rotators have been setup. Contact your site developer.
    See the documentation to learn how to setup a rotator."
    So it seems the filter is not working.

    No further debugging notes show up.
    It's WP 3.5 on a local machine (MAMP).

    In case you need more information – feel free to pepper me.

    Regards,

    Kirsten

  6. Hal Gatewood
    Member
    Plugin Author

    Posted 2 years ago #

    @Netzialist Can you post what you put into your functions.php?

  7. jeryj
    Member
    Posted 2 years ago #

    Hi Hal,

    I'm having the same issue as @Netzialist.

    I figured it out on my end, and it might have been the same for others. At the end of the readme, the code you give to add to the functions.php is this:

    The easiest way to add a placeholder is to put this in your functions.php
    
    function set_FlexSlider_hg_rotators()
    {
    	$rotators = array();
    	$rotators['homepage'] = array( 'size' => 'homepage-rotator' );
    	return $rotators;
    }
    add_filter('FlexSlider_hg_rotators', 'set_FlexSlider_hg_rotators');

    Notice that FlexSlider is camelcase, while it needs to be written in all lowercase. Changing 'FlexSlider to "flexslider" fixed it for me.

    Thanks for making the plugin!

  8. Hal Gatewood
    Member
    Plugin Author

    Posted 2 years ago #

    Fantastic! Thank you, I will update the code.

    I remember doing a find and replace on the readme file at some point because I know how wordPreSS people like to get the correct capitalisation.

  9. jeryj
    Member
    Posted 2 years ago #

    :)

  10. kwatts22
    Member
    Posted 2 years ago #

    The problem with it not showing is your just adding the functions for the slider into wordpress. The slider itself still has to be created on the index.php page for it to show in your website. That part must of been left out on purpose so you have to purchase the plugin.

  11. reysar
    Member
    Posted 2 years ago #

    One big question... and silly to how on earth do i add slides into the admin after creating a new slide i dont have the option to add images....

    Can you advice me on that please

  12. kwatts22
    Member
    Posted 2 years ago #

    You have to upload them through the media manager and copy the image url so that it can be pasted into the plugin. The developer didn't add the function to be able to upload them directly.

    Here is step by step to help you. Your's may be a little different depending on the version of wordpress that your running.

    On the left side click Media
    Next click the Add New
    Upload your image and make sure to give it a alt text for the search engine
    Click on Save and it will go back to the screen that shows all your pictures.
    Click on the name of the picture that your wanting to use in the slide
    Where it says File URL copy everything in that box by highlighting it the right click your mouse and select copy.
    Next go to the slide that your working on adding the images and paste that url you just copied into the image url and your done.

  13. Hal Gatewood
    Member
    Plugin Author

    Posted 2 years ago #

    Not sure what kwatts22 is talking about here. But you simply use the Featured Image uploader. More information in the WordPress Codex:

    http://codex.wordpress.org/Post_Thumbnails#Setting_a_Post_Thumbnail

  14. reysar
    Member
    Posted 2 years ago #

    But then that means that i can add only 1 image per slide?, or can i add "N" images to the slide i am building my site from ground so before finish homepage and move to the other files i would like to know about that thank you.

    I really appreciate your help

    Reysar Davila

  15. Hal Gatewood
    Member
    Plugin Author

    Posted 2 years ago #

    It works with 1 image per slide and multiple slides per rotator.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • HG Slider
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic