The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

WordPress HTTPS (SSL)
[resolved] SlideRocket Issue (6 posts)

  1. Stu
    Posted 3 years ago #

    On domains without Sliderocket that I have forums in we have an image upload capability that works seamlessly with this awesome HTTPS plugin.

    On a single domain that we serve a few presentations in it appears that Sliderocket is the culprit in breaking the stated function.

    I'd be so appreciative if there is some guidance on, and if this can be fixed. After reading other support issues I'm at a loss so far.


    console.log('Secure External URLs: ... http://app.sliderocket.com/app/fullplayer.aspx?id=xxxxx

    [WARNING] Unsecure Element: <iframe> - http://app.sliderocket.com:80/app/fullplayer.aspx?id=xxxxxxx


  2. Mike Ems
    Plugin Author

    Posted 3 years ago #

    It seems as though the content is available over HTTPS, but I think I see the issue.

    Try adding this to your domain mapping:
    app.sliderocket.com:80 => app.sliderocket.com

    I think the plugin is checking for the validity of https://app.sliderocket.com:80 which doesn't work at all. Very strange that port 80 is in that URL. I'll have to check for that in my code now. Thanks for reporting this.

    Let me know if that domain mapping rule fixes it. If not, I should be able to get this fixed in the next release.

  3. Stu
    Posted 3 years ago #

    Thanks, but that and a variety of iterations are a no go. Interesting that Google bought this company and is an app available to Google Apps users. I thought all their stuff was in https however....

    On the page in question, it is in an iframe - apscnp.org/veterans-benefits/ - I have left your debugging feature on if you'd care to look. Absolutely every other page works. Great plugin Mvied.

  4. Mike Ems
    Plugin Author

    Posted 3 years ago #

    They do host it all over HTTPS. The issue is the frame is coded as http://app.sliderocket.com:80. The plugin does not blindly change every external resource to HTTPS because not every resource will be available over HTTPS. The plugin tests for the validity of the resource. In this case, when it changes the scheme to HTTPS, you end up with https://app.sliderocket.com:80/ which does not work because port 80 is specified in the URL.

    I've modified my plugin to also remove the port in this case because the HTTP port will never be valid for the HTTPS address.

    If you could, please give the development version a shot and let me know if the issue persists.

  5. Stu
    Posted 3 years ago #

    Sorry, I don't see a difference but.. I restarted fpm and purged everything after installing your dev version (b). I am using Ngnix. This is not a huge problem as the content is being delivered fine, just instead of the "green" lock in the address bar I get the yield icon (chrome). Of course this may be an issue you want to continue to tackle and I will assist in any way I can. I tried this with, and without the mapping you indicated above.

    Thanks Mvied,

  6. Mike Ems
    Plugin Author

    Posted 3 years ago #

    Yeah, and even when I fix this bug, you will still get those warnings because even if you call those slideshows over HTTPS, they load HTTP content in them.

    I set up the same iframes in my test environment and got it fixed. Thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress HTTPS (SSL)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic