Support » Fixing WordPress » Slider – Theme conflict with old Jquery Version

  • vince23

    (@vince23)


    Hey, Im using an outdated theme (showcase) and the Revolution slider.

    I m having trouble gettin the slider to work as produces the follwing error message :

    The Current Version of jQuery:1,4,2
    Please update your jQuery Version to min. 1.7 in Case you wish to use the Revolution Slider Plugin

    I ve tried to replace the old js-files in the theme folder but it didn’t help.

    here are the linked jd-files in the fuctions.php:

    wp_enqueue_style( 'showcase', get_bloginfo( 'stylesheet_url' ) );
      wp_enqueue_style( 'font-titillium', get_template_directory_uri() . '/fonts/titillium/stylesheet.css' );
      wp_enqueue_style( 'font-leaguegothic', get_template_directory_uri() . '/fonts/leaguegothic/stylesheet.css' );
      sc_enqueue_style( 'ie6', get_template_directory_uri() . '/ie6.css', 'IE 6' );
      sc_enqueue_style( 'ie7', get_template_directory_uri() . '/ie7.css', 'lt IE 8' );
      wp_enqueue_script( 'jquery', get_template_directory_uri() . "/js/jquery-1.4.4.min.js", null, '1.4.4', false );
      wp_enqueue_script( 'md5', get_template_directory_uri() . "/js/md5.js", null, null, false );
      wp_enqueue_script( 'prettyjs', get_template_directory_uri() . "/js/pretty.js", null, null, false );
      wp_enqueue_script( 'jquery.tools', "http://cdn.jquerytools.org/1.2.5/full/jquery.tools.min.js", array('jquery'), null, false );
      wp_enqueue_script( 'showcase_scripts', get_template_directory_uri() . "/js/scripts.js", array('jquery', 'jquery.tools'), null, true );
      if ( $is_IE ) {
       wp_enqueue_script( 'DD_belatedPNG', get_template_directory_uri() . "/js/DD_belatedPNG.js", false, null, false );

    What I did is: I replaced the “jquery-1.4.4.min.js” with a modern version (1.9 or 2.0). What am I doing wrong ?

    Could you guys help me out ?

Viewing 7 replies - 1 through 7 (of 7 total)
  • WordPress core automatically loads jQuery v1.8.3, but for some reason it looks like your theme is loading an older version instead.

    You can try commenting out this line:

    wp_enqueue_script( 'jquery', get_template_directory_uri() . "/js/jquery-1.4.4.min.js", null, '1.4.4', false );

    …by adding two forward slashes before it, like this:

    // wp_enqueue_script( 'jquery', get_template_directory_uri() . "/js/jquery-1.4.4.min.js", null, '1.4.4', false );

    That should prevent your theme from loading its version of jQuery, allowing WP core to load its version instead.

    vince23

    (@vince23)

    Thanks for the answer but that didnt work.

    Well, the issue is clearly that your theme and/or some other plugin is loading an outdated version of jQuery. One way to resolve the issue would be to add this to your functions.php file:

    function jquery_reset_06232013() {
        wp_deregister_script( 'jquery' );
        wp_register_script(
            $handle    = 'jquery',
            $src       = '//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js',
            $deps      = array(),
            $ver       = '1.8.3',
            $in_footer = true
        );
        wp_enqueue_script( $handle );
    }
    add_action( 'init', 'jquery_reset_06232013', 999 );

    This should fire after anything else that is registering the script; de-register it; and then register it using a version from Google’s CDN.

    If that works, that means something besides your theme is registering the wrong version of jQuery and should be hunted down and destroyed. 🙂

    vince23

    (@vince23)

    sorry but that didnt work aswell.

    I really dont know what is causing the problem.

    The only plugin I have is qtranslate which doesnt use jquery at all.

    So it must be the theme (which is from 2011 I think).

    vince23

    (@vince23)

    Does it make a difference if I work locally (with bitnami)

    or online ?

    @vince23, hope you solved it already.

    Make sure that if you’ve created a child theme that the parent isn’t calling an older version. If it’s twentyeleven, it might be related to the call in showcase.php:


    wp_enqueue_script( 'twentyeleven-showcase', get_template_directory_uri() . '/js/showcase.js', array( 'jquery' ), '2011-04-28' );

    Hi,

    I am having the same problem with my site and cannot figure out what is stopping wordpress from reading the the new jqery update.

    @vince23 did you solve the problem? how?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Slider – Theme conflict with old Jquery Version’ is closed to new replies.