Support » Plugin: Smooth Slider » Slider size shrinking in tabbed module

  • I have 4 different sliders with 4 different IDs that I am calling within the content of a tabbed module in WordPress (in page builder in the Divi theme). The first default tab that is open displays the slider just fine, but once you click on the other tabs, the slider is a ridiculously reduced size, almost thumbnail sized. I know it is not the slider itself, because I tried switching the IDs over to the first time and it displayed fine. It’s something to do with the way the tabbed module is displaying the sliders. I’m wondering if anyone else out there has noticed this problem and what solution there could possibly be.

    Thanks!

    https://wordpress.org/plugins/smooth-slider/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi there,

    Please send us link of page where you embedded slider, so that we can recreate issue and help you.

    Thank you,

    Regards,
    Sagar.

    I would have done that, however I am working on a private development server that only users on-campus can access. Is there a way to take screen shots and email to you somehow?

    Moderator Andrew Nevins

    (@anevins)

    You can upload screenshots & then link to them in your posts: http://snag.gy/

    But screenshots won’t help someone debug your issue

    Thank you. I will try to re-create within a public domain and get back to you with the link today.

    I now see what the problem is, I just don’t know how it’s happening. Let’s see if this bit of information can stir up some thoughts….

    The div tag around the 1st slide is this:

    <div style=”max-width: 790px; margin: 0px;” class=”smooth_slideri”>

    But in the second, third and forth slide, it is this:

    <div style=”max-width: 100px; margin: 0px;” class=”smooth_slideri”>

    So it turns out, it IS the max-width: 100px creating the problem. I double-checked my custom CSS to make sure I didn’t place a max-width of 100px somewhere, and there is not. I double checked the Smooth Slider settings and played around with the widths of the slide images there. Didn’t have an affect. Can anyone conceive of where else the max-width: 100px might possibly be coming from?

    Thanks.

    Hi there,

    It seems that that width get applied because of other plugin’s CSS. When you set Slider Width from setting panel in smooth slider that width get applied to all slides similarly.

    Try to send your link ASAP, so that we can help you.

    Thank you for your patience.

    Regards,
    Sagar

    So as it turns out, I have a second dilemma preventing THIS one from being solved. Here’s the gist of my situation…

    I am developing a new WordPress site with the DIVI theme, which uses page builder, to eventually replace the site which uses an older WordPress theme that does not use page builder. Page builder provides a tabbed content box module for which I’m housing this plugin. The first problem lies in that the url which hosts the development DIVI site is not available to anyone off this local network, so I cannot share that link. I thought I would be able to mock up the plugin in the current WordPress theme, which is accessible to the outside, however, I cannot simulate the plugin in the tabbed module, because it’s not set to DIVI! And, I cannot change the current site’s theme to DIVI until I figure out this issue.

    After some poking around, I actually was able to finagle the CSS to make the widths work…but it seems like an unnecessary solution….

    Ok, for those who still want to try to solve this issue, I was able to mock up a test within another website that uses the DIVI theme. Here’s the link!

    smoothslidertest

    The first slide looks fine, but when you click on the other tabs, you’ll see the issue…

    Hi Sagar,

    Thank you for your suggestion. I tried putting a fixed height on the following rule ….

    .smooth_slider {height:300px !important;}

    …but unfortunately, that did not change anything. However, I did try height. Interestingly enough, the problem is fixed by using max-width specifically, not just width. Here is the style that solved the problem:

    .smooth_slider .smooth_slideri {max-width:900px !important; }

    I’m sure this problem will probably happen again for novice users who aren’t experienced with CSS and they won’t know how to fix this. Doesn’t it seem to you like something can be improved upon with the plugin or within the tabbed module in DIVI to prevent this sort of issue from occurring?

    Thanks again for all of your patience and help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Slider size shrinking in tabbed module’ is closed to new replies.