Easing Slider
Slider not working after updating (7 posts)

  1. mharrisr
    Posted 3 years ago #


    I have updated the plugin and imported the old setting, tried removing the plugin and installing several times but no success. I also sent an email to you regarding this issue, please fix it soon

    Thank you




  2. MatthewRuddy
    Plugin Author

    Posted 3 years ago #

    Hi @mharrisr, this doesn't look like a plugin issue. It looks more like a problem with your WordPress installation not allowing the plugin to save its settings to the database. This could link to your web host not fully supporting WordPress, or it not being setup correctly.

    Can you enable WordPress debugging so I can check for any errors being printed? You can do this by editing the 'wp-config.php' file found in the WordPress filesystem, and changing this line:

    define('WP_DEBUG', false);

    To this:

    define('WP_DEBUG', true);

    This will tell us any errors that are occurring in the admin area.

  3. mharrisr
    Posted 3 years ago #

    Yes I have changed the above code. Look at the admin

  4. MatthewRuddy
    Plugin Author

    Posted 3 years ago #

    Hi again. Yes, there appears to be quite a lot of errors occurring. Something is interfering with the saving process, using the update_option WordPress function (standard practice).

    Screenshot of errors

    From here, there isn't really I can do on behalf of Easing Slider to fix the issue as it doesn't appear to actually be a bug with the plugin. Something is going wrong with WordPress saving process. This can be a plugin conflict, or host issues.

    I'd try disabling all of the other plugins you have activated, then re-installing Easing Slider. Make sure it is the only plugin active, and see if it works. If not, try also changing your theme. If you are still having problems, contact your host.

    If disabling all of the plugins makes Easing Slider work, carefully re-enable each plugin one-by-one until activating one of the plugins breaks Easing Slider. This is the plugin that is causing the problems. You'll need to disable it, or find an alternative.

  5. mharrisr
    Posted 3 years ago #

    Yes I have tried all as per your advice but not working, contacted host in chat they said its not hosting related. please help

  6. mharrisr
    Posted 3 years ago #

    I have installed another slider plugin but it works fine, so the issue is in Easing slider only. All other plugins are intact.

  7. MatthewRuddy
    Plugin Author

    Posted 3 years ago #

    @mharrisr, there is nothing I can do. I can't access you sites database so I'm not sure if the variables are getting saved correctly or not. The errors were showing that the variables coming from the database weren't objects. They should be saved as objects, so either they aren't getting saved correctly or they aren't getting saved at all. It could also be a case that the typecasting is failing, which is extremely unusual and unlikely.

    There isn't anything I can do about this. This is an isolated issue that no one else appears to be having. If your WordPres install is having problems serializing and saving objects to the database, there isn't anything I can do about that. I can't think of any other reason that would cause the plugin's save process to fail like this. It's a very simple system, and uses WordPress inbuilt functionality.

    It could also be issues regarding the json_encode function, but it should be fine. Again, would be host related if that is the case.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Easing Slider
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.