Support » Theme: Dazzling » slider not properly configured

  • Resolved matthew.unsworth



    I downloaded your theme and first of all would like to say I love it!

    I can’t seem to get the slider to work though.

    I’ve created a category called homepage-slider and set it to this category in the theme options.

    I’ve created a post, put the category as homepage-slider and also set the featured image to a certain image.

    Is there something else I’m missing? Do I have to put something in the content on the post?


Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi @matthew.unsworth,

    Sorry to hear of the problem you are having.

    It seems you have configured the slider correctly.

    Could you please share the page URL from your site where it’s not displaying correctly so that i can troubleshoot it?

    Kind Regards,

    Slider is not properly configured

    A bit crazy, if you are in the settings of the Theme, the slider does work in the Preview. But if you close the Preview you get the message “Slider is not properly configured”

    Hi @blatze,

    It’s working fine on my test site using latest version of Dazzling theme.

    Please make sure you have configured the slider on the following path as described below.

    Admin Area -> Appearance -> Customize -> Dazzling Options -> Slider options

    To enable slider tick checkbox “Check if you want to enable slider” and you will see that two no options will appear “Slider Category” and “Number of slider items”
    Select category from dropdown to use for slider
    Now select number of slides to be used in slider (newest Posts from that category will be used)
    Make sure you have Featured Images selected for those Posts.


    I had the same thing happen.
    To fix I created a post under a different category. Went back to Admin Area -> Appearance -> Customize -> Dazzling Options -> Slider options and selected the correct category with the dropdown. If you only have one category it won’t work.

    Hope that works for you.

    No sorry, did everything just like matthewunsworth!
    But it still does not work. Had to Finish the site so I deactivaded it… 🙁

    Hi @blatze,

    Sorry to hear that you deactivated it but if we can be of any further assistance then feel free to ask it.


    I have the same problem, I tried with everything described but nothing seems to work.

    I have two posts with featured images in the category “featured”, one in another category, I’ve adde two more categories (3 total), the slider settings are:
    Check if you want to enable slider (checked)
    Category “Featured”
    Number of slide items “3”

    And I still get the error message “Slider is not properly configured”

    What I’m doing wrong?


    In the admin >appearance > customize > options >slider if you don’t actually get a dropdown of categories, then it won’t work. Can you confirm that you have multiple categories to choose from in the admin?

    Like this: Screenshot

    In the dropdown menu i see only categories with blog post in it

    you can see it here:

    Not sure if this helps any, but here is my structure:

    Hi Lorenzo,

    Please try changing your all slider settings like number of slide items etc.

    Best Regards,

    Maybe you need a category ONLY for the Slider? Can´t try it anymore..

    Hi There,

    As per the Forum Welcome,you should post your own topic and to help keep support thread separates could you please create your own thread for your question here instead of replying on others thread as it makes the thread messy and hard to read.

    If you want to you can also add reference of this thread in your newly created thread.

    We would be more than happy to help you on your new thread.

    @ilomo Glad it’s working fine for you.


Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘slider not properly configured’ is closed to new replies.