Support » Plugin: Smart Slider 3 » Slider not loading due to incorrect cache location

  • Resolved Pradeep

    (@pmaheepala)


    Hello there,

    I just transferred a development site to a client’s server and noticed that everything except the Smart Slider is working. Upon inspection, I noticed that Smart Slider loading is failing with this message:

    Loading failed for the <script> with source “https://www.xyz.com/app/cache/nextend/web/combined/7f8ab01004ef472eabbf38625dd1f453.js”.

    Both the development and production instances are Roots Bedrock and the slider is working fine on the development instance. I noticed that if I manually change that URL to “https://www.xyz.com/wp/app/&#8221; it finds the cached script. Could you kindly guide me how to get this fixed? I tried deleting the plugin and reinstalling it, manually removing the cache and flushing cache from everywhere including SS3 with no luck.

    Many thanks in advance.

    Best regards,

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @pmaheepala

    After moving your site to another domain, usually it’s enough to just clear the slider’s cache:
    https://smartslider.helpscoutdocs.com/article/1757-moved-site

    But if the problem seems persistent after the slider’s cache was cleared, then maybe the old domain is still set somewhere in WordPress, as we’re asking down the site URL from WordPress itself:
    https://smartslider.helpscoutdocs.com/article/1757-moved-site#domain

    Thread Starter Pradeep

    (@pmaheepala)

    Hello @nextend_ramona

    Many thanks for the reply. I’ve tried all those with no luck. I could be wrong but I’m inclined to believe this is because of a some other reason, as everything else is working fine.

    As mentioned before both the development and production instances are using Bedrock. SS3 is working fine on development instance and even on production, when I preview the sliders, they work fine. And I can see when I remove cache manually SS3 creates cache in the right place too.

    However, on the production server, which is on SiteGround, we have to add an extra htaccess file to point it to the correct folder.

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^xyz.com$ [NC,OR]
    RewriteCond %{HTTP_HOST} ^www.xyz.com$
    RewriteCond %{REQUEST_URI} !web/
    RewriteRule (.*) /web/$1 [L]

    For some reason this is causing (I can’t think of anything else) an issue for SS3 as it doesn’t work without the extra /web/ in it’s cache location URL.

    In other words, I need to find a way to tell only SS3 (as everything else is working fine) to look for the location this instead of this

    Not sure if this is something you’ve come across before. It’s great if you could find me a workaround for this as I would like to keep both Bedrock and SS3, as they are working fine together everywhere else.

    Many thanks in advance!

    Plugin Support Ramona (from Nextend)

    (@nextend_ramona)

    Hi @pmaheepala

    We’ll set up a testing environment soon and see if we can reproduce the problem.

    In the meantime can you tell me if the problem persists if you temporarily turn off the Combined option? You can do that at Global settings > Framework:
    https://smartslider.helpscoutdocs.com/article/1785-framework

    Thread Starter Pradeep

    (@pmaheepala)

    Hello @nextend_ramona,

    Many thanks for the reply. I wasn’t aware of this option at all so I just gave it a try. Yes it does work when I turn off the ‘Combined’ option. Not sure if it’s a bad thing performance wise but I’m glad that I now have a working solution. I’ll mark the post as resolved but please feel free to let me know if there’s anything I could do to help you with testing.

    Keep up the amazing work!

    Best regards,

    Pradeep

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Slider not loading due to incorrect cache location’ is closed to new replies.