Support » Plugin: Slider by Soliloquy - Responsive Image Slider for WordPress » Slider doesn't work after upgrade to V2.0!

  • Resolved bykaraanne

    (@bykaraanne)


    Hey Support Team!

    My Slider was working fine and is very straightforward to use (thank you for that!) but after the upgrade to v2.0 it becomes wonky. I did not touch anything and even after the dimensions were specified correctly the slider becomes a tiny box on my page! I can’t think of how to solve it.

    Thank you in advance.

    https://wordpress.org/plugins/soliloquy-lite/

Viewing 15 replies - 31 through 45 (of 50 total)
  • I too am having serious issues with the sizing after upgrading to 2.0.4. Looks to only happen on initial load, if I resize the window it snaps into correct size. The issue can be seen at http://www.kingstonhealthcare.com/location/kingston-vermilion/ and clicking the photo tour tab.

    Any help would be greatly appreciated. Worked fine in previous version and need to get this resolved today. If there is a CSS change I need to do, please let me know but from what I can tell this is happening at the plugin level.

    Okay, I was able to solve this in the short term by adding
    .soliloquy-image-slide {width:100%!important;}

    So far I am not experiencing any ill effects from this. The slider is still responsive and looks to be functioning properly. I have a pretty basic slider so this might be mess up other sliders but it’s definitely working for me. Really didn’t want to have to downgrade. After some more testing I did notice that I was only experiencing these issues when inside a tabbed area. The sliders were working fine on 2.0.4 when not in a tabbed area.

    @jaldrich – it sounds like the slider needs to be reloaded on tab click. Add this to your theme’s functions.php file:

    add_action( 'wp_footer', 'tgm_soliloquy_reload_slider_on_tab_click', 10000 );
    function tgm_soliloquy_reload_slider_on_tab_click() {
    
        ?>
        <script type="text/javascript">
            jQuery(document).ready(function($){
                $('#detailed-locations-tabs li a').on('click', function(e){
                    if ( soliloquy_slider ) {
                        $.each(soliloquy_slider, function(idx, obj){
                            obj.reloadSlider();
                        });
                    }
                });
            });
        </script>
        <?php
    
    }

    Hi,

    It looks like I am having the same problem as many others after the upgrade. My website is http://www.dnlrec.com. Could you please help?

    Thank you!

    @katybailey – remove the “floatleft” class from the div that is holding the slider and it should work properly. 🙂

    @ThomasGriffin I reverted to using a single image. But you can see the invisible slider here: http://zafait.com/advertising/

    I have 2 sliders on this one page.

    1st – Below ‘Zafait.com Homepage Advertising’: Flyer &/or Video Slideshow of your promotion
    2nd – Below ‘A Zafait.com Promotion & Business Webpage’: A slideshow of your business on location.

    Any further questions or issues, please let me know. Thanks in advance for your assistance.

    @Zafait.com – clear out your CloudFlare CDN cache and you should be good to go. There are some CSS styles that need to be refreshed – it is working, just some old styles conflicting with the latest updates.

    @ThomasGriffin – Thanks. Works perfectly now. (y)

    After upgrading today, slider images would not appear if using “Scroll Horizontal” or “Scroll Vertical” transitions. “Fade” transition is working correctly. I found a css fix.

    soliloquy.css line 104 has this:
    .soliloquy-container .soliloquy-item {
    min-height: 1px;
    min-width: 1px;
    display: none;
    }

    overriding display to block fixes the issue for me and no apparent side effects yet

    @gazornenplat – this was fixed in 2.1.6 of Soliloquy Pro that was released today. 🙂

    Each update brings me more problems!

    Since I upgraded to 2.0, one of the sliders in my website became too small.
    See at http://www.bioaquaria.com (top right banner in the header).
    There are other bugs going on.
    In http://www.bioaquaria.com/?page_id=878 there’s a slider with covers of some magazines. The slow horizontal scrolling sliding effect is no more slow and it doesn’t seem to scroll horizontally. Also now there’s only one thumbnail where should be 7!
    All the slides with thumbnails have this problem!

    I have Developer v2.1.5 installed. Please let me know how to install again version 1.5.7 until all this issues get solved.

    Thank you

    Horizontal scrolling and thumbnails issues are now solved with v2.1.6.

    I am still having the same issue with the banner slider in the header of my page: http://www.bioaquaria.com
    This was OK before upgrading to v2.0.

    @bioaquaria – I’ve got someone working on this bug right now. It appears there is an issue anytime Soliloquy is set inside a container that is being floated. I am trying my best to get this resolved soon – I’m sorry about that!

    Thanks.
    Hope you can solve this soon.
    I’ve just up updated to v2.1.7 and the issue persists.
    I changed the banner to a static image, while this issue isn’t fixed.
    Keep up the good work!

    I updated today to v2.1.9 and the container issue isn’t solved!

Viewing 15 replies - 31 through 45 (of 50 total)
  • The topic ‘Slider doesn't work after upgrade to V2.0!’ is closed to new replies.