WordPress.org

Support

Support » Plugins and Hacks » Slider disappears when NextGen is activated.

Slider disappears when NextGen is activated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the same issue using the Asteria theme. The Nivo Slider that is embedded in the theme disappears from the home page when I activate NextGen.
    The site is http://relpnc.org/

    Plugin Author photocrati

    @photocrati

    @nikiontime – Unfortunately if a “paid” theme author doesn’t want to help you with this then we may not be able to do much more for you but we can try. We will need a Bug Report (http://www.nextgen-gallery.com/report-bug/) with your site specifics.

    We will also need log in and FTP credentials for your WordPress installation, please include those with the Bug Report.

    @paul Hartman – Your issue is most likely not the same and you should create your own topic, but as you noted you have “Nivo Slider that is embedded” this is a common issue for those themes, but the actual plugin by the developer of Nivo Slider appears to work fine with NextGEN Gallery. I would take this up with your theme author to see if they can address the issue. Otherwise, please start your own topic.

    Thanks!

    – Cais.

    Hi, i have the exat same issue than Nikiontime with the Organic Shop Theme
    Can i have your help too ? Best regards
    Benjamin Billard

    The symptoms were:
    Activating the NextGen Gallery plugin caused the homepage slider to disappear. The theme is Asteria. http://relpnc.org

    I noticed an error in Firebug console:
    $(“ul.main-navigation”).superfish({
    TypeError: $ is not a function

    Found a solution here:
    http://stackoverflow.com/questions/12258282/typeerror-is-not-a-function-wordpress

    Original code in footer.php

    <!-- Initialize the Slider, Dropdown Menu and jQuery Tabs -->
    <script type="text/javascript">
    $(window).load(function() {
    	$('#slider').nivoSlider();
    });
    </script>
    
    <script type="text/javascript">
    $("ul.main-navigation").superfish({
    		animation: {height:'show'},   // slide-down effect without fade-in
    		delay:     1200               // 1.2 second delay on mouseout
    	});
    </script>

    Revised code in footer.php

    <!-- Initialize the Slider, Dropdown Menu and jQuery Tabs -->
    <script type="text/javascript">
    jQuery(document).ready(function($) {
    	$(window).load(function() {
    		$('#slider').nivoSlider();
    	});
    });
    </script>
    
    <script type="text/javascript">
    jQuery(document).ready(function($) {
    	$("ul.main-navigation").superfish({
    		animation: {height:'show'},   // slide-down effect without fade-in
    		delay:     1200               // 1.2 second delay on mouseout
    	});
    });
    </script>

    Your theme may be similar.

    Thank you for your answer. Unfortunatly the problem looks to be somewhere else. I dont have the same error in firebug and the php looks different !
    Anyway, thanks again for your answer !
    Best regards
    Benjamin Billard

    Plugin Author photocrati

    @photocrati

    @billardbenjamin – I believe you have submitted a Bug Report on this … let’s keep the conversation there for the time being; or, please start your own topic so we can address your specific issue (if you did not submit the Bug Report).

    Thanks!

    – Cais.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Slider disappears when NextGen is activated.’ is closed to new replies.