Support » Plugin: Carousel Slider » Slider Disappeared After Update to Version 2+

  • Hello Sayful! 🙂

    Thanks for this plugin, I really think that it’s the best-looking Carousel Slider plugin available and have been using it for over a year now.

    After upgrading to version 2.0.0, 2.0.1 and 2.0.2 I receive the following critical error after activation, which relates to the wp-admin/admin-ajax.php file:

    An error of type E_ERROR was caused in line 37 of the file /var/www/vhosts/***hidden***/httpdocs/wp-content/plugins/carousel-slider/classes/Admin/Setting.php. Error message: Uncaught Error: Class 'CarouselSlider\Supports\SettingAPI' not found in /var/www/vhosts/***hidden***/httpdocs/wp-content/plugins/carousel-slider/classes/Admin/Setting.php:37 Stack trace: #0 /var/www/vhosts/***hidden***/httpdocs/wp-includes/class-wp-hook.php(303): CarouselSlider\Admin\Setting->settings() #1 /var/www/vhosts/***hidden***/httpdocs/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters() #2 /var/www/vhosts/***hidden***/httpdocs/wp-includes/plugin.php(470): WP_Hook->do_action() #3 /var/www/vhosts/***hidden***/httpdocs/wp-settings.php(578): do_action() #4 /var/www/vhosts/***hidden***/httpdocs/wp-config.php(94): require_once('/var/www/vhosts...') #5 /var/www/vhosts/***hidden***/httpdocs/wp-load.php(50): require_once('/var/www/vhosts...') #6 /var/www/vhosts/***hidden***/httpdocs/wp-admin/admin-ajax.php(22): require_once('/var/www/vhosts...') #7 {main} thrown

    The website however still remains functional in both the frontend & backend, although the only place where I use the Carousel Slider is on the homepage and the slider has completely disappeared from that section, not even the shortcode is visible.

    I’ve since reverted it back to version 1.10.2 as this was stable. Does the version 2+ require that I re-build the slider using the images I used previously for it to be visible again, or how else could I help with troubleshooting this error? 🙂

    Thanks again!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sayful Islam

    (@sayful)

    I don’t know why you are getting this error. Can you try to deactivate and delete old plugin and install again latest version. Don’t worry, deleting plugin won’t remove your existing content (though it is good to take a backup always). If you are getting same error, let me know.

    Thread Starter seanbremner

    (@seanbremner)

    Hi there Sayful! 🙂

    Unfortunately, this did not solve the problem.

    I’ve reverted back to 1.10.2 & as you said there was no issues with lost content, although I did look at the settings of the new version 2.0.5 and just remembered that I previously needed to set the “Style & Scrips” Optimization to Always rather than Optimized, as when it’s on Optimized the slider disappears exactly as it does in version 2.

    This isn’t a big problem for me though, as I use Asset Cleanup Pro to disable it on all other pages except for the home – but I have also tested whether Asset Cleanup is affecting the new version 2 by using Query String ?wpacu_no_load to bypass but the result is still the same.

    This exact issue happened ocassionally with some versions between 1.0~1.10 but I had never reported on it then, do you think this time it could possibly be related to the Optimization setting above?

    I’m happy to remain on version 1.10.2 until we can find a fix.

    Thank you!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Slider Disappeared After Update to Version 2+’ is closed to new replies.