Support » Theme: PostMagazine » Slider Broke

  • felix25

    (@felix25)



    All of a sudden the slider broke, I do not know what happened, I didn’t update the theme at all or edit the code for a couple months, and the code was working fine before. It just stopped rotating this morning.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Theme Author bloggingthemes

    (@bloggingthemes)

    That is odd…. what version is your WordPress, and do you know if anything in your website updated automatically, such as plugins?

    UPDATE: Forgot to ask, when was the last time you saw it working?

    Theme Author bloggingthemes

    (@bloggingthemes)

    I just looked at your source code… it’s all different and missing stuff compared to the live demo site for this theme. Something has drastically changed the code.

    Double check your slider settings in the customizer and disable the slider, then re-enable it (save and publish), then check the other settings there to make sure you have the correct ones set. Also enable the Show Navigation, Auto play, and pagination checked.

    felix25

    (@felix25)

    I saw it working last night and all the source code is different because I made a bunch of changes so it just showed pictures while rotating, nothing else. And I tried turning off, saving, and turning on all the settings. I will try again but it did not work last time.

    Theme Author bloggingthemes

    (@bloggingthemes)

    What changes did you make? Is it possible to reverse what you changed?

    felix25

    (@felix25)

    I took out the read more function and the linking function, I could reverse it, but I do not want to.

    felix25

    (@felix25)

    I just want the slider function to work, it was working last night and then this morning it did not, I did not touch any code in that time

    Theme Author bloggingthemes

    (@bloggingthemes)

    I just went to your site to look at your slider source code again but got this:

    Error establishing a database connection

    Theme Author bloggingthemes

    (@bloggingthemes)

    I see your site is back up again.
    Anyway, I’m still not sure what was done or happened where it was working then on its own suddenly not. However, if you simply want a slideshow with no content, no titles, no links (because in your source code, all this is empty), but just want a rotating slideshow of images, I recommend going for a simple image slideshow plugin.

    The slider in this theme, when enabled, is for posting actual posts that have featured images and meant to have content show on top of each slide image with a link to that post.

    ….this might be the solution for you.

    felix25

    (@felix25)

    Okay, I have put in a new slideshow but how do I have it above the promo box area?

    Theme Author bloggingthemes

    (@bloggingthemes)

    You will want to put the slider in the Banner sidebar position…providing that the slider you are using has either a widget or a shortcode for it?

    To make sure this only shows on the front page, you need a plugin to publish it on select pages. This article might help:

    https://www.bloggingthemestyles.com/blog/wordpress-tutorials/show-hide-wordpress-widgets/

    felix25

    (@felix25)

    The theme just broke out of nowhere, can you help explain this?

    Theme Author bloggingthemes

    (@bloggingthemes)

    Your site is not loading the theme’s stylesheet and wondering if a plugin is causing a conflict with something. Something is obviously breaking your site layout too.

    If this happens, it’s generally recommended to disable one plugin at a time, and after you disable each one, test your site, then do another plugin, test it, then another, etc.

    It could be a plugin that is corrupted or it could be a plugin that is conflicting with another.

    felix25

    (@felix25)

    If the stylesheet turned out to be the problem, how would I know?

    Theme Author bloggingthemes

    (@bloggingthemes)

    I can guarantee it won’t be the stylesheet…things like this usually point to a plugin issue. This is also the first time I seen someone have this happen from all the downloads and active users of this theme, so I have a feeling it will be a plugin….however, disabling plugins one-by-one and testing the site out after each one should pinpoint where the problem is.

    If in the event there is something conflicting with the theme itself, then we can look into what it is.

    felix25

    (@felix25)

    Every single plugin was deactivated one by one and then checked against the website and nothing fixed it, the website is still messed up.

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.