Support » Theme: Harmonic » skrollr.js on tablets with theme

  • Resolved eamonncoyne

    (@eamonncoyne)


    Hi,

    I am having problems with the theme when accessing links (or possibly simply clicking/tapping on the page) on tablets in landscape mode specifically between width 1024px and width 640px (or min-width: 40.063em and 64.063em as the theme refers to it). The links are not clickable/followable with the following errors on inspection in chrome (as borne out on tablets/iPads):

    [Intervention] Unable to preventDefault inside passive event listener due to target being treated as passive. See https://www.chromestatus.com/features/5093566007214080

    this is pointing to:

    if(!rxTouchIgnoreTags.test(currentElement.tagName)) {
    				e.preventDefault();
    			}

    in file:
    http://www.hoyorkney.com/wp-content/themes/harmonic/js/skrollr.js?ver=`20141207

    This error appears to happen for any click on the page.

    As a comparison the same in portrait mode is fine and gives:

    Resource interpreted as Document but transferred with MIME type application/pdf: “http://www.hoyorkney.com/?ddownload=4168”.

    this is pointing to:

    //It was a tap, click the element.
    
    var clickEvent = document.createEvent('MouseEvents');
    							clickEvent.initMouseEvent('click', true, true, e.view, 1, touch.screenX, touch.screenY, touch.clientX, touch.clientY, e.ctrlKey, e.altKey, e.shiftKey, e.metaKey, 0, null);
    							initialElement.dispatchEvent(clickEvent);
    						}

    in file:
    http://www.hoyorkney.com/wp-content/themes/harmonic/js/skrollr.js?ver=20141207

    The problem can be seen in other browser inspectors as well (always refreshing after resizing viewport)

    Disabling plugins doesn’t solve the problem.

    Changing the theme to Twenty Seventeen removes the problem.

    It only seems to happen for some of the links on the page (possibly the first one?) as can be seen here

    The site in question is http://www.hoyorkney.com

    Bye-for-now and hope you can help,
    Éamonn

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi there,

    Thanks for reporting this. Our developers have received another notice about this as well, so I’ve added your details to that report.

    You might try adding the following CSS to the Appearance > Customize > Additional CSS area in case it helps until a fix can be made to the theme:

    #slide-feature {
    	z-index: -1;
    }

    Hi,

    Unfortunately the above CSS simply disabled the theme integrated ‘Read More’ button on slide 1 of all the pages/posts so didn’t help really.

    Éamonn

    Hi Éamonn,

    Thanks for the notice. I didn’t experience that when I tested it, but in that case it may be best to wait for an update to the theme.

    Hi Éamonn,

    Thanks for reporting this issue! We’ve added a fix and resubmitted Harmonic — the next version, 1.1.2, should be available for download shortly.

    If this doesn’t fix the problem you’re seeing, or if you have any questions at all, please let us know!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘skrollr.js on tablets with theme’ is closed to new replies.