Support » Plugin: Strictly Auto Tags » Skip Pre-Tagged Posts option faulty

  • Resolved tesztmester

    (@tesztmester)


    Hello!

    I am not able to use autotag option, because when I uncheck “Skip Pre-Tagged Posts” option and press save everything looks OK, but when I revisit this page again (not refreshing), this setting is automatically set to “yes”, so the plugin does not generate new tags. I do not know why it forgets my wished sittings?!

    Could you please be that kind and check it?

    Thank you for in advance!

    Kind regards,
    Gabor

    https://wordpress.org/plugins/strictly-autotags/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Strictly Software

    (@strictly-software)

    Hi

    Well I have checked in on both the paid for and free version and on multiple sites I use it on and I have “Skipped Pre-Tagged Posts” checked at the moment. If I hit “Save” it comes back and is still checked.
    If I re-visit the admin page it is still checked.

    Maybe do the standard
    -check for JS errors in your console
    -check for issues with your browser e.g try a different one – I use Chrome

    I cannot think of what else to say as you are the only person who has complained of this and I cannot replicate the issue.

    Sorry.

    Rob

    Hi Rob, firstly thanks for this plug-in. Don’t need the advanced features of the paid-for version but donated £5 for your efforts.

    just to let you know I have the same problem with v2.9.6.

    Deselect the Skipped Pre-Tagged Posts option, save the options, go to a post, update it, save draft, no new tags are generated, go back to the options and the option is ticked again.

    Working in Chrome on a PC using the Highwind Theme. I have tried deactivating and reactivating the plug-in but no change. Not sure how to check for JS errors.

    Scott

    Plugin Author Strictly Software

    (@strictly-software)

    Well in Chrome you can use the Developer options go to the little 3 lines in the top right of the browser > more tools > javascript console > errors.

    In FireFox you can go to tools > javascript errors or install web developer toolbar and it will show 3 ticks/crosses in the right side. click on the javascript errors to see them.

    I would try it in multiple browsers and see if you get errors.

    Also try the standard
    -de-activate ALL other plugins and try it to see if it works
    -un-install ALL other plugins and try it to see if it works
    -try it in different browsers
    -ensure you are hitting “save” when you leave the admin area so that the page refreshes. Is the box ticked again when the page reloads?

    As I said I cannot replicate the problem and no-one else has had it and if it’s the only tickbox NOT staying ticked it would suggest a JS error or not saving the page properly when you leave it. Maybe you are getting an error message when you do hit save and not fixing the problem it is complaining about. if there is an error it is likely the tickbox value wasn’t saved either.

    So try those and see if it helps.

    I am seeing this in the Javascript console when I deselect the “Skipped Pre-Tagged Posts”

    Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check http://xhr.spec.whatwg.org/.
    VM362:63 GET http://nikkomsgchannel/e?001f0050005e005500430041006e005200510056005c005200…5d0050005e0049001f0051005d0047005d000b005f005f005d0059005e005f0050005b005e

    This is before I save. When I click save I get:

    Consider using ‘dppx’ units, as in CSS ‘dpi’ means dots-per-CSS-inch, not dots-per-physical-inch, so does not correspond to the actual ‘dpi’ of a screen. In media query expression: print, not all, (-webkit-min-device-pixel-ratio: 1.25), (min-resolution: 120dpi).

    Does this point to anything? Definitely remains ticked after saving. If I refresh the page after saving the box remains unticked, but if I go to a post and then return it becomes unticked.

    Thanks for your help.

    Scott

    Plugin Author Strictly Software

    (@strictly-software)

    Tried again and cannot replicate the issue.

    The CSS issue has nothing to do with it. You should be able to toggle it to just show “errors” or “javascript”.

    I don’t know what the first error is but seems like some sort of remote API call from another plugin. Maybe try the de-activating of all other plugins and then test it.

    Standard help you should always try is listed on my FB page (pls like if pos!)

    > https://www.facebook.com/strictlysoftware/posts/364830366999257

    Very hard to debug an issue no-one else or myself can replicate. There is no logical reason why it should be ticked after a save / refresh and then go back to unticked again. Only the save admin options button controls whether that option is ticked or not – nothing in my actual code that is run on save_post to do the tagging.

    Really you need to debug it. E.G go into my files, add your IP into the me function and enable ShowDebugAutoTag. Then run it – write the article first then copy up the file with debug enabled before saving.

    Then you can see all the debug messages and something in there might stand out.

    Having skipped tagged posts just means when you edit an existing post with tags already against it then no tagging is done. And in reality (I have it ticked all the time) you would have Skipped Tagged Posts enabled as you shouldn’t want to re-tag posts with tags already against it.

    Also it shouldn’t stop NEW posts from being tagged at all as any new posts won’t have tags so it will tag them.

    So I don’t know why you would want this unchecked anyway however I will look into it again.

    I will try some debugging when I have time. As you say there is probably another plug-in affecting this.

    For now I just delete all the tags created when I save the first draft and then save the draft again. Autotag then starts again and produces a complete set of keywords.

    Plugin Author Strictly Software

    (@strictly-software)

    New Premsium Version has gixed the bug with checkboxe / boolean values thst prevented the values from being saved.

    http://blog.strictly-software.com/2015/02/new-premium-version-of-strictly-auto.html

    I might be putting the fix in the free version when I get some free time but I have been up all night (after 11 hours st work the cleaners even telling me to go home as they leave at 8PM and I am still there.

    Got work in 1 hour! No chance of any sleep then!

    However if you wanted to fix it yourself you can replace this function with this code.

    In GetOptions (search for it)

    In the 2nd branch, the first sred defaults replace

    if(IsNothing($options['skiptaggedposts'])){
    	$options['skiptaggedposts'] = true;
    }

    With

    if(!isset($options['skiptaggedposts'])){
    	$options['skiptaggedposts'] = true;
    }

    And that should fix it.

    Hope that helps – YAWN LOL

    Rob

    Thanks Rob. Will try it later.

    Red Bull day coming up?

    Plugin Author Strictly Software

    (@strictly-software)

    Red Bull – you mean the flying plane thing up town?

    Yes it is, not really my thing though more into horse racing.

    By the way the new free version of the plugin should have all the fixes for the checkboxes in it now.

    Thanks

    Rob

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Skip Pre-Tagged Posts option faulty’ is closed to new replies.