Support » Plugin: ShiftNav - Responsive Mobile Menu » Skins not working :(

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author sevenspark


    Hi bartek,

    Can you post a link to your site so I can see what you are referring to?

    The Loading ShiftNav notice only appears to logged-in administrators. It disappears as soon as the script has loaded, but it allows you to tell if something is going wrong. None of your end users will ever see it. If it bothers you, you can hide it with CSS. I’ll probably add an option to disable it in a future version.



    Of course, link to my site:

    From 20 of April link will change to (i will activate site for public).

    Thank You!



    Plugin Author sevenspark


    Hi Bartek,

    What is happening is that your theme (or possibly another plugin) is overriding the Menu Walker for ShiftNav. So instead of ShiftNav controlling the output of the menu, the theme is controlling it. As a result, ShiftNav’s stylesheets don’t apply, since the markup doesn’t match (the ShiftNav classes aren’t present).

    What is likely going on is that the theme/plugin is filtering all the menus on your site and replacing the Walker with its own (which would be pretty sloppy). You’d need to find the filter that is acting on the menu to change the walker and prevent it from changing ShiftNav’s walker. The likely filter hook to look for is wp_nav_menu_args. Unfortunately I can’t tell any more without seeing the theme code.

    Hope that helps!



    Thank You very much!

    I made a progess. I found file named “themeple_custom_menu”.

    In this file i found code:

    add_filter('wp_nav_menu_args', array(&$this,'change_menu_arguments'), 100);

    When i deleted it, menu is working a little bit better, but still this is “not it” 😉 Can You PLS check it in my site? Mayby we can fix it?

    Site url: Menu is active.


    Best regards


    Ps. I can send You some code, files if necessary. I would like to plug work, I’m very concerned about this…

    Plugin Author sevenspark


    Hi Bartek,

    I took a look at your site, and the menu seems to be functioning properly now – looks like you found the right filter 🙂

    What about it doesn’t seem right currently? Perhaps you need to clear your cache? You’re using the light skin – perhaps you meant to switch to the dark skin?




    It works just fine! 🙂 I want to buy PRO version (hover submenus option) but first i need to apply another feature witch is very important to me.
    I need Your help with it…

    On my site I have theme mobile menu button in header. After clicking this button, I would like to list the shiftnav menu instead of the standard theme menu. I’m trying to do it myself… but it does not work.

    1. This is code for this button:

    <a href="#" class="mobile_small_menu open"></a>

    2. This is css code for this button (style.css)

    /* Small Menu Responsive */
    .mobile_small_menu{display:none; width:45px; height:45px; float:right;}{background:url('img/res_m_open.png') no-repeat;}
    .mobile_small_menu.close{background:url('img/res_m_close.png') no-repeat;}
    .dark_version{background:url('img/res_m_open_dark.png') no-repeat;}
    .dark_version .mobile_small_menu.close{background:url('img/res_m_close_dark.png') no-repeat;}
    /* End Responsive Menu */

    css file that image can be viewed by a browser plug-in

    3. This is css code for this button (bootstrap_responsive.css)


    I do not know 100% if there are any other css class defining it.

    I know that my request relates more of my template than your plugin, but I would be very grateful for your help!

    I’m working on it, changed the code to:

    shiftnav_toggle( 'shiftnav-main' , '' , array(
         'id' => 'my-special-toggle',
         'el' => 'span',
         'class' => 'mobile_small_menu open'
    ) ); ?>

    Step by step is better 😉 but after clicking on the button opens a menu both…

    so… 🙂 I finally made it! It’s working! Thank you for your help.
    I hope that I will have no other “questions”;)

    Plugin Author sevenspark


    Hi Bartek,

    Glad to hear you got it sorted out! Yes – as you’ve implemented it – the strategy would be to use the Toggles API to create a ShiftNav toggle for the main menu, then apply your theme’s background image to it 🙂

    All the best,


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Skins not working :(’ is closed to new replies.