WordPress.org

Forums

WP LaTeX
Size option of inline code not working (3 posts)

  1. stefga
    Member
    Posted 2 years ago #

    I tried to set a size for my Latex formula, but it did not work as expected:

    (#1) Not working: $latex e^{\i \pi}&s=4$
    (#2) Working: $latex e^{\i \pi}& amp;s=4$
    (without the space)

    I changed in wp-latex.php the regular expression so it includes
    the non-escape ampersand:

    wp-latex,php line 118:
    preg_match( '/.+((?:& #038;|& amp;|&)s=(-?[0-4])).*/i', ...<br />
    Now, both versions work.

    Do I miss an option that makes #1 work out of the box? If not,
    would you change the regular expression for the next WP Latex relase,
    please?

    Kind Regards
    Stefan

    https://wordpress.org/plugins/wp-latex/

  2. Michael Adams (mdawaffe)
    Member
    Plugin Author

    Posted 1 year ago #

    Could you please try version 1.9.3-beta (currently available at http://downloads.wordpress.org/plugin/wp-latex.zip)?

    I believe it fixes the encoding issues as well as some image alignment issues.

  3. stefga
    Member
    Posted 1 year ago #

    Hi Michael!

    Thank you! The resizing works perfectly now!

    Kind Regards
    Stefan

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP LaTeX
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic