Support » Theme: Satisfy » Size of post box on front page – not allowing correct display

  • Resolved drjs

    (@drjs)


    Hi again!

    One more issue πŸ™‚

    I think that the fixed size of the posts displayed on the front page is causing some display issues for me.

    On the front page of my site the ‘read-more’ box only seems to display for each post if the tags are only one line each. It seems to be confined by the size of the post-box.

    I also notice that the photos in the posts on the front page have been cropped too.

    Is it possible to increase the size of the ‘post box’ frame or allow it to be an indeterminate size (dictated by the post extract/ photo?)

    I also notice that links are also not displaying in a few of the posts on the front page. When I click on the post the links do display there. They are there but randomly not on the front page.

    (I do have a child theme up and running – frifran.com).

    Thanks again! πŸ™‚

Viewing 8 replies - 1 through 8 (of 8 total)
  • Theme Author Webbjocke

    (@webbjocke)

    Hi I had a look and the read more buttons issue seems to be the common wordpress problem when having “excerpt snippets” set for posts. I think adding the following code to your child themes functions.php should fix it.

    function my_excerpt_fix ( $excerpt ) {
        if ( has_excerpt() && ! is_attachment() ) {
            return $excerpt . satisfy_excerpt_more( null );
        }
        return $excerpt;
    }
    add_filter( 'get_the_excerpt', 'my_excerpt_fix' );

    About the cropped images on front page that can’t really be changed (for the moment). Your alternative here is to set the option “Featured images in blog loops” to “full” and they won’t be cropped but have bigger size though.

    What links do you mean are not displaying? Could you give an example?

    Great, I will add the scrips to the child functions. php and play around with the featured images in blog loops.

    On links not displaying in all the posts on the front page there are links to other pages in the excerpts – e.g. second post down: Super Quick and Healthy Banana, Peanut Butter and Almond Smoothie there is a link in the text to the recipe at the start of the second sentence – it doesn’t show as a link. I guess it might not be designed to?

    Many thanks!

    Hi – I added the code above and no change to ‘read more’ πŸ™

    I purged my cache etc.

    Many thanks!

    Theme Author Webbjocke

    (@webbjocke)

    That’s weird. I actually use the code above on a site and it works. Are you using a plugin for the excerpts or the “normal” WordPress ones from inside your posts? Just try and disable all your plugins for a quick sec and see if that changes anything.

    Nope WordPress pretty much removes all links and html from the excerpts it extracts from posts. In custom excerpts links work though if you add them with html.

    Hi!

    Sorry for the delay.

    I deactivated plugins, purged the cache and no change.

    πŸ™

    Theme Author Webbjocke

    (@webbjocke)

    Hm are you using “<!β€”moreβ€”>” tags for excerpts in your posts? I just noticed the theme doesn’t support those and the code I gave you won’t work then. There will probably be some fix for this in the next update, but right now you could try and remove the code I gave you and replace with this and see if that fixes it.

    function my_excerpt_fix ( $excerpt ) {
        if ( $excerpt && ! strpos( $excerpt, '<a class="btn btn-default read-more"' ) && ! is_attachment() ) {
            return $excerpt . satisfy_excerpt_more( null );
        }
        return $excerpt;
    }
    add_filter( 'get_the_excerpt', 'my_excerpt_fix' );

    You are a star! It worked. Thank you so much!!!

    (I am using “<!-more> tags)”.

    Theme Author Webbjocke

    (@webbjocke)

    Haha great! No problems

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Size of post box on front page – not allowing correct display’ is closed to new replies.