Support » Networking WordPress » 'siteurl' on site edit page gets re-written upon logout/login

  • Resolved dgroos

    (@dgroos)


    I can’t easily post to my sites, and, when students post comments to some post I’ve made, they often get taken to a blank screen (using firefox).

    I’ve done the basic troubleshooting that I’ve found on the web (eg clear cache/cookies, disable all plugins) to no avail.

    The following steps illustrates what I do and the problem:
    –In superadmin box in the dashboard I click on ‘sites’.
    –I click on ‘edit’ for one of my sites such as the groosp1 site. I have these settings shown:
    —-Domain http:// is: fle.mpls.k12.mn.us
    —-path is: /wpblogs/groosp1/
    —-I’ve got checked: Update siteurl and home as well.
    —-It has the incorrect siteurl: http://fle.mpls.k12.mn.us/wpblogs
    —-I scroll a ways down to the ‘home’ setting and it has the correct address: http://fle.mpls.k12.mn.us/wpblogs/groosp1/
    –I update the siteurl to: http://fle.mpls.k12.mn.us/wpblogs/groosp1
    –I scroll to the bottom and click ‘update options’.
    –Next, if I click on ‘add post’ at the top of this screen it will go to a post creation page BUT not for the correct site but instead has this address: http://fle.mpls.k12.mn.us/wpblogs/wp-admin/post-new.php (note the missing /groosp1 in the address). If I publish this post and view it I find it at the root blog page… http://fle.mpls.k12.mn.us/wpblogs/blog/2010/11/16/test5-post/. However,
    –If I click on a link to the /groosp1 site, then click on ‘site-admin’, then click ‘add post’, create a post and post and view it, It works just find, creating a post on the groosp1 site.
    –next I log out
    –log back in
    –go to superadmin box, again to to ‘sites’, click on ‘edit’ for the groosp1 site.
    –and it has re-written the siteurl again back to the root site: http://fle.mpls.k12.mn.us/wpblogs
    –and if I try to post a blog it will go to the site root, not the groosp1 site I was at.

    I’ve worked many hours on getting a handle on problem, I’d appreciate any links or ideas to check!
    David

Viewing 15 replies - 1 through 15 (of 20 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Where do you actually have wordpress installed?

    And in the config file, what value does it have for $base?

    dgroos

    (@dgroos)

    My /var/www/html/wpblogs/wp-config.php says:
    $base = ‘/wpblogs/’;

    Thanks for such a quick reply!
    David

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Turn off all your plugins, including those in mu-plugins (if applicable) and try it again.

    dgroos

    (@dgroos)

    The results described in the first post are with all plugins deactivated and cache/cookies emptied. Unless there is a separate page I don’t know about for mu-plugins?

    The mu and the wp3 folders are installed in the same folder on the server: /var/www/html/:
    drwxr-xr-x 5 root root 4096 Aug 22 13:43 .
    drwxr-xr-x 6 root root 4096 Apr 19 2010 ..
    -rw-r–r– 1 root root 79 Jun 23 07:12 index.html
    drwxr-xr-x 5 root root 4096 Mar 3 2010 wordpress-mu
    drwxr-xr-x 2 root root 4096 Aug 22 13:43 wp09
    drwxr-xr-x 5 apache wpgroup 4096 Nov 16 22:03 wpblogs

    Our district senior web engineer installed mu first last year–I don’t think I ever used that. When wp 3 came out he created a new install for that. He had been experimenting with various AD authentication schemes but was never able to get them to work and I needed to get going using this great software with my students. As mentioned, I have deactivated all plugins, including those LDAP/AD plugins.

    Thanks for your help,
    David

    Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    The siteurl field is ignored if the ‘Update siteurl and home as well’ is checked. The siteurl will be updated to http:// + domain + path.

    What is DOMAIN_CURRENT_PATH set to in your wp-config.php?

    Either your config, wp_site record, wp_blogs records are misconfigured or a plugin/theme is causing that.

    dgroos

    (@dgroos)

    Thanks for explaining how the siteurl works. I’m using the 2010 theme. I did try to upload a new picture last year but didn’t succeed. Wonder if I should try another theme – which might be a standard one?

    I don’t have a DOMAIN_CURRENT_PATH in my wp-config.php file.

    This is what I have:
    $base = ‘/wpblogs/’;
    define(‘DOMAIN_CURRENT_SITE’, ‘fle.mpls.k12.mn.us’ );
    define(‘PATH_CURRENT_SITE’, ‘/wpblogs/’ );
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOGID_CURRENT_SITE’, ‘1’ );

    In case this is useful, here’s my wp-config file: http://pastie.org/1305989

    I’ve located wp_site:
    /var/lib/mysql/wpblogs/wp_site.MYD
    /var/lib/mysql/wpblogs/wp_site.MYI
    /var/lib/mysql/wpblogs/wp_site.frm
    and likewise my wp_blog:
    /var/lib/mysql/wpblogs/wp_blogs.frm
    /var/lib/mysql/wpblogs/wp_blogs.MYD
    /var/lib/mysql/wpblogs/wp_blogs.MYI

    I’m not sure which of these to check or exactly how I would check them?

    THANKS Andrea and Ron for your help.
    David

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Everything Ron posted about has nothing to do with your theme. the theme is irrelevant – it can;t control base values such as site url.

    dgroos

    (@dgroos)

    ???

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    You said:

    I’m using the 2010 theme. I did try to upload a new picture last year but didn’t succeed. Wonder if I should try another theme – which might be a standard one?

    I’m saying it’s not the theme.

    dgroos

    (@dgroos)

    Any other ideas or links? I really need students to use the sites but they can’t…

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Did you check the db like ron suggested?
    Did you disable all your plugins, including any in the mu-plugins folder? (Yes, I know you said you deactivated plugins)

    Also, go look at the Edit page for any other sub site. Is it correct? Do not edit it. Do not save. Just LOOK.

    Can you post to any other sub-site?

    dgroos

    (@dgroos)

    Did you check the db like ron suggested?

    Check database? I think that means check one of the following files, right? Which one? Do I just open it with a text editor?
    I’ve located wp_site:
    /var/lib/mysql/wpblogs/wp_site.MYD
    /var/lib/mysql/wpblogs/wp_site.MYI
    /var/lib/mysql/wpblogs/wp_site.frm
    and likewise my wp_blog:
    /var/lib/mysql/wpblogs/wp_blogs.frm
    /var/lib/mysql/wpblogs/wp_blogs.MYD
    /var/lib/mysql/wpblogs/wp_blogs.MYI
    Please link me to a page that explains what you mean about ‘checking the db’.

    Did you disable all your plugins, including any in the mu-plugins folder?

    I don’t know how to disable a plugin if it isn’t on my plugins page at the root level of my site.

    Also, go look at the Edit page for any other sub site. Is it correct?

    —I’ve got 1 root site and 9 sub sites.
    —When I click on the ‘edit’ button to get to each of those 10 sites, the all properly say at the very top: “Edit Site – http://fle.mpls.k12.mn.us/wpblogs/teachers” for whatever site it is. This example is at the sub-site called /teachers.
    —Looking at the Siteurl on each of the 9 sub-site edit pages, I see that on 7 of them it lists the root site, and on 2 of them it lists the proper site!!! But even when I try to add a new post on one of these 2 sub-sites, the post always goes to the root level blog. Thanks for your continued help!

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Check database? I think that means check one of the following files, right? Which one? Do I just open it with a text editor?
    I’ve located wp_site:
    /var/lib/mysql/wpblogs/wp_site.MYD
    /var/lib/mysql/wpblogs/wp_site.MYI
    /var/lib/mysql/wpblogs/wp_site.frm

    Um, no. Ideally you;d have some way to manage the database, like phpmyadmin or a way to search if you know SQL from the command line. Do you hace a tech guy at your school?

    Did you disable all your plugins, including any in the mu-plugins folder?

    I don’t know how to disable a plugin if it isn’t on my plugins page at the root level of my site.

    look at your folder. under wp-content. Is there one called mu-plugins or not? If not, don’t worry about it.

    —Looking at the Siteurl on each of the 9 sub-site edit pages, I see that on 7 of them it lists the root site, and on 2 of them it lists the proper site!!! But even when I try to add a new post on one of these 2 sub-sites, the post always goes to the root level blog

    you’ve definitely got something wrong with your site, and if you can’t narrow it down you may have to just reinstall it.

    dgroos

    (@dgroos)

    I ‘checked the database’ with phpmyadmin and nothing stood out–not sure what to check…

    Andrea, when you say,
    … just reinstall it. Do you mean simply doing a reinstall of wordpress 3.0.1 from the reinstall page (I did this and didn’t help). or are you saying create a new database and a new install and importing in the data? Technology–great when it works…

    Thanks again

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    or are you saying create a new database and a new install and importing in the data?

    That’s exactly what I’m suggesting. If you have time but no money, this may fix it.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘'siteurl' on site edit page gets re-written upon logout/login’ is closed to new replies.