Support » Networking WordPress » Sites not appearing under Tools

  • Hi

    I am very new to this so please bare with me. I’ve completed a WP installation and have one site up and running using MAMP on my Mac. I’d like to add more sites to the installation and understand that the initial stage is adding this line of code:

    define('WP_ALLOW_MULTISITE', true);

    Into the wp-config.php file which I have done (I have checked that there is only one wp-config file and yes, it is this one). The section of the code around this line looks like this:

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    define('WP_ALLOW_MULTISITE', true);
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    I’ve made sure the ‘ are not “s and I’ve refreshed the WP admin browser and also logged off and back into it. Sites refuses to appear in the tools menu.

    I am at a loss as to what is not happening or what I am doing wrong. I am not the most technically minded person, but wondered if it was something to do with MAMP and did I need to configure something in the database settings?

    I’d very much appreciate any help you can give.

    Best wishes,

    Kris

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Re-read http://codex.wordpress.org/Create_A_Network

    After you add define('WP_ALLOW_MULTISITE', true); the directions tell you to refresh and look for the Network Setup item in your Tools menu. Use that menu item to go to the Create a Network of WordPress Sites screen.

    Yes, thanks. As per my first message that’s what I did. Refreshed the browser (and even logged out of admin and back in again) – but neither led to Network Setup appearing in tools.

    All I get is

    TOOLS >

    Available Tools
    Import
    Delete Site
    Export

    Thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Delete Site

    Uh.

    That shouldn’t show up unless you already have WP Multisite set up.

    Go into your database. Look for these tables:

    wp_blogs
    wp_blog_versions
    wp_registration_log
    wp_signups
    wp_site
    wp_sitemeta

    Hi

    No, I don’t have any of those showing under the tables section in the wordpress database running on MAMP.

    Does the delete site refer to the site I’ve already built in WP?

    Thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Okay, that’s really weird.

    Are you 100% sure you’re looking at the right site? You’re looking at localhost and not a wordpress.com hosted site?

    Don’t hit delete until we figure this out!

    The URL is:

    http://aachiropractic.wordpress.com/wp-admin/

    I installed WP on my Mac, running on MAMP. I made the alterations on the wp-config.php file and refreshed, nothing changed.

    Thanks

    Kris

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Look at that URL would you?

    aachiropractic.wordpress.com/wp-admin/

    That isn’t your locally installed site at all 😀 Your default MAMP address is localhost:8888 I think.

    Check http://documentation.mamp.info/en/mamp/preferences/ports

    Hi there

    No this is the information on MAMP:

    Host localhost
    Port 8889

    Not 8888

    Thanks

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Either way, going to ANYTHING.wordpress.com is never gonna work. You’re basically saying ‘When I fill my car with gas, the truck is still empty.’ 😉

    You want to go to localhost:8889/wp-admin

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Sites not appearing under Tools’ is closed to new replies.