Support » Plugin: MainWP Dashboard » Sites No Longer Listed Under Sites (v4)

  • Resolved kwebdesign

    (@kwebdesign)


    Sites doesn’t show any sites, yet I can still sync and update all my sites.

    I’m also struggling to find where I access extensions from to clear cache etc after updates?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Forgot to mention that I’ve tried Incognito based on the clear cache post.

    I’ve also been through the repair database process.

    • This reply was modified 2 months, 3 weeks ago by kwebdesign.

    This info might be of help to you.

    To View Sites

    In the Overview page look at the Connection Status widget. There is an inverted triangle near the top right hand side of this widget. It is just next to where it reads ‘Hide Details’. Click there and you can elect to See All Sites. This will list all sites in the Overview page and you can click to view the site admin. The problem is that each time the Overview page is reloaded you need to reset the widget to elect See All Sites.

    I also have the issue that no sites show under the Sites menu but then I feel they are better viewed in the Overview page.

    Extension Settings

    You can view the each extensions settings page by clicking the triangle next to Extensions in the left-hand Main WP menu.

    You must delete the pre version 3 extensions then install version 4 extensions by visiting the main Extensions page (accessed through the left-hand menu).

    Other

    A few months ago when version 4 was in alpha status I sent a support request to Main WP to express that the new UI looks nice but is functionally cumbersome because it requires users click more buttons and visit more admin pages when all most of us want to do is access site dashboards and update software from the overview page. My feedback was ignored. Hopefully enough Main WP users offer the same feedback and thereby prompt the devs to rethink the Overview page and its design requirements.

    Thanks for this information…

    I’ve managed to show the sites via the overview.
    I tend to check for disconnected sites via the sites menu each day.
    I guess they should show up when syncing but best to be sure.

    I’ve deleted the old extensions via the server, as they weren’t visible in the admin.
    I’ve installed the new extensions, which now appear on the server again, but still aren’t showing in the admin. I’ve tried Incognito after this to ensure it wasn’t caching.

    It does look better and I’m not a massive fan of stuff being moved around, but who is. There’s normally a good long term reason for doing so. They’re providing an amazing system for the price, so I’ll cut them a bit of slack.

    • This reply was modified 2 months, 3 weeks ago by kwebdesign.

    There is a Screen Options cog at the top right of the Overview page. You can use this to enable or disable widgets. Some of those extensions might need their widget to be made visible.

    Now this bit is less obvious. When you view the Extensions in the new Extensions Manager page you can click the green title of each extension to navigate to the settings/admin page. You do have to activate each extension through the Extensions manager page (there is a green button under the Test Login widget).

    Do the other left-hand menu items expand and contract when you click on them? All of mine do and that’s how I access the admin page for each extension. You’ll know to check this but because others looking for answers might need a prompt I’ll say it anyway: if the menus are not expanding then a plugin script or ad blocker could be interfering with the UI.

    For reference I use Opera on Linux, which is pretty similar to Chrome (same core). I’ve not tested Main WP 4 in Firefox, Vivaldi, Brave or other browsers.

    I’m hopeful some of the convenience of the older layout is returned in a later release. You could be right in that Main WP are waiting for wider feedback on the present UI before they re-introduce features. You are right, they do a great job with Main WP.

    Screen options isn’t showing anything I want to enable…
    https://snipboard.io/61ZItX.jpg

    Plugins directory shows the installed extensions…
    https://snipboard.io/aK4I01.jpg

    Extensions page shows the missing extensions…
    https://snipboard.io/QPWBnj.jpg
    I can’t activate them, if they’re not there.

    Install extensions…
    https://snipboard.io/l0hKnT.jpg
    I’ve already ticked and installed, which is how they ended up in my plugin directory.

    I’m on Chrome Windows.

    I see what you mean now. I thought they showed as installed in the Extensions Manager but that you were unable to access their settings.

    Could be a quirk in the extensions installer that prevents extensions showing up if the pre v.4 ones are not deleted through WP Admin > Plugins. Maybe something in the deactivation uninstallation script needs to trigger so that Main WP 4 is certain the pre 3 ones have been deleted. I’m clutching at straws here, though.

    Sometimes helps to use Optimize WP to check the database and delete transients.

    I know you’ve cleared your browser cache. Maybe there’s a server cache or CDN cache that needs to be cleared too.

    I would delete the extension files then use the Extensions Manager to install them again and send a ticket to Main WP through their website if re-installation doesn’t work.

    Thanks Lee… You’ve help me resolve part of my issues!

    I went to remove the extensions via plugins, as I thought removing V4 would probably trigger the same code. It turns out they weren’t enabled.

    I kind of just expected the extensions to continue working on upgrade.
    I removed the old ones via the server because without the regular plugins menu displayed, it’s easy to forget it’s there. When I installed the new ones, I’d assumed MainWP would activate them.

    • This reply was modified 2 months, 3 weeks ago by kwebdesign.

    Yeah, it’s a bit temperamental at the moment but I’m sure Main WP’s excellent dev team will iron out the kinks soon.

    Good luck with the second part of the issue!

    It turns out that I’d missed the filter button at the edge… It was set to “disconnected” and I’d changed to “all statuses”, but hadn’t clicked filter.

    • This reply was modified 2 months, 3 weeks ago by kwebdesign.

    That’s good to know. I can see all my sites there now too. Thanks for letting me know.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.