Support » Networking WordPress » Sites created via admin not installing/created

  • Resolved webmasterdrake



    I’ve searched through the forums and havent found the same issue i seem to have.

    I just enabled multisite. I ran the setup and everything seemed to go fine. I updated the wp-config and the .htaccess file as instructed.

    I can view the network admin area and tried creating two new blogs. These blogs show up in the admin area, however the folders/databases are not being created on the server.

    No idea where to begin to look here. Any help is much appreciated.

Viewing 13 replies - 1 through 13 (of 13 total)
  • No actual folders are created. The folders are virtual.

    Look in your MySQL database with PHPMyAdmin or such. There should be wp_# tables, where # is incremented by 1 for each new site.

    If those aren’t getting created, you likely haven’t given your database account all permissions to the database.

    I have a ‘wp_blogs’ table that does show the other sites I created. The id is incrementing, the site_id is 1 for all. However, when I try to access the dashboard or site I get a page not found error like “The requested URL /site1/wp-admin/ was not found on this server”.

    Do you have wp_2_[name] tables in your database?

    the blog_id is for the new blogs.

    Since you picked subfolders, your sever has to be reading the htaccess file you had to create during network setup.

    @tim: I do not.

    @andrea_r: OK…How do I know if my server is reading the .htaccess file? Here are the contents of my .htaccess file (maybe I did something wrong there?):

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    htaccess file is fine. if its not being read, then it doesn’t matter what’s in it.

    Ask you webhost. tell them you made htaccess file changes to that install and nothing’s happening.

    My webhost is actually an Amazon EC2 instance that I created…so that would be me 🙂

    Does it need to chmod to something?

    I was able to take a crash course in apache2 config and enabled AllowOverride All for my /var/www/ directory and VIOLA!

    Thanks for pushing me in the right direction!

    and enabled AllowOverride All for my /var/www/ directory

    yep. that’s it. 🙂

    @andrea_r Is there something in multisite that creates a 302 redirect?

    No? Check your plugins. using domain mapping? what about privacy settings?

    Nope. I was getting ready to install domain mapping and the site was hosed. Amazon says a 302 redirect was created (at some point) and I sure didn’t do it. Just trying to figure out how that would happen. Thanks for the response.

    check your htacces file? kinda hard to say with no link and no hint as to where the 302 is occurring at. 😉

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Sites created via admin not installing/created’ is closed to new replies.