[resolved] Sites appearing blank after creation, need help... (10 posts)

  1. Spencer Hill
    Posted 1 year ago #

    I've created clean installation of WordPress Multi-Site here: http://www.weareinfluence.com

    But when I create a new site the admin and front end are displaying blank: http://demo.weareinfluence.com/wp-admin/

    There are no Plugins, and no additional Themes installed. No special configurations beside initial setup.

    I chose the sub domain option and I have a wildcard record for the domain.

  2. What's in your .htaccess?

    Is the theme Twenty Fourteen still installed?

  3. Spencer Hill
    Posted 1 year ago #

    .htaccess is below, but it is completely unmodified beside it's creation during the MU install process.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    And yes, Twenty Fourteen is installed.

  4. That's fine :) Nothing having ANY .htaccess would be a problem.

    Can you check your server error log and see if there's anything? A plain white page is usually a PHP error you see.

  5. Spencer Hill
    Posted 1 year ago #

    It's actually not generating any error logs. And with wp_debug enabled no errors are reported on screen either.

  6. http://demo.weareinfluence.com/asdfdsaf is a 404 that is NOT a WordPress one, so I think that your .htaccess isn't being honored or DNS is weird...

    How did you add subdomains to your server? NOT to WP, but to the virtual conf settings?

  7. Spencer Hill
    Posted 1 year ago #

    Sorry, /asdfdsaf isn't a page I created so I'm confused how that plays into this?

    I didn't add any subdomains on the server. I've only created the subdomain through WordPress and added a wildcard DNS record.

  8. That's the point :) If I visit a page that doesn't exist, I should get a WordPress 404 page. If I don't, that means the server's not set up right.

    You have to add the subdomain in three places:

    1) DNS - tells the WORLD the subdomain exists
    2) Server - tells the server "This subdomain lives here"
    3) WordPress - Tells WP what to show.

    You forgot step 2. Do you know how to add subdomains in general to your account in cpanel or panel or whatever you have?

  9. The Portland Company
    Posted 1 year ago #

    Thanks for the explanation, I didn't understand that I had to create a subdomain. But now that I think about it I realize that there has to be a virtual conf record regardless of whether or not there is a actual directory created for that.

    Totally didn't connect that in my brain.

    Thanks so much!

  10. It's logical the second time around :)

Topic Closed

This topic has been closed to new replies.

About this Topic