WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » [Resolved] sitemaps problem with google webmaster tools

[Resolved] sitemaps problem with google webmaster tools

Viewing 7 replies - 1 through 7 (of 7 total)
  • I started “Default Settings”
    Got this Warning: Warning: Cannot modify header information – headers already sent by (output started at G:\xampp\htdocs\wordpress\wp-admin\menu-header.php:163) in G:\xampp\htdocs\wordpress\wp-includes\pluggable.php on line 876
    ??????????????????
    What can I do?

    I wonder if this is related to the problem I’m seeing at the moment…

    Google Webmaster tools reports a 404 error on my sitemap and when I go to the WordPress SEO “XML Sitemaps” settings and click the view XML sitemaps button, I also see a 404 error.

    Logging in via FTP confirms that all my sitemap files are gone… and I can’t figure out how to regenerate them with the WP SEO plugin.

    Well I have no idea what is going on here… My sitemaps all magically reappeared by themselves, which is very odd.

    Hello? Are you highjacking my post? I read your problems, but what have they to do with mine?

    Get out of here !! 😉

    Boris

    PS: It would be nice, if you could just delete your comments here and leave my topic up to me! Thanx!!

    Update on the indexing-issue:

    It seems that

    post_tag-sitemap.xml
    and
    category-sitemap.xml

    are being contributed, but not being indexed.

    What could be the reason for that?

    post-sitemap.xml and page-sitemap.xml are just finde..

    Best Boris

    Plugin Author Joost de Valk

    @joostdevalk

    That image is indeed being blocked by your robots.txt:

    http://www.hebammenblog.de/robots.txt

    Your tag pages all have this:

    <meta name="robots" content="noindex, follow" />

    not coming from my plugin but in your theme. That’s the issue.

    I am getting a similar problem using the Yoast WordPress SEO plugin sitemap.

    my site is prestigedecking.com

    Webmaster tools is telling me there are errors/warnings. There are five sitemaps generated by the plugin:

    /attachment-sitemap.xml reading “pending” with 1 error (URL is blocked by robots.txt)
    /category-sitemap.xml reading 3 warnings (URLs are blocked by robots.txt)
    /ngg_tag-sitemap.xml with no issues
    /page-sitemap.xml reading 8 warnings (URLs are blocked by robots.txt)
    /post-sitemap.xml reading 8 warnings (URLs are blocked by robots.txt)

    One of the things I don’t understand about this, is the blocked URLs are not showing up under the blocked URLs listed in Webmaster tools.

    The troubling thing about these warnings is that robots.txt is blocking main pages on my website like “about”

    I also don’t understand why it says “8 warnings” for instance, but when I click the hyperlink it only shows three examples and two are the same URL

    Do I need to submit these sitemaps to my host server?

    I have scoured the web to try and understand what all of this means. I am not an advanced user (which should be obvious), so simple instructions as to a solution are appreciated.

    Help please!

    Thanks,

    Chris

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] sitemaps problem with google webmaster tools’ is closed to new replies.
Skip to toolbar