Support » Fixing WordPress » Sitemaps don't work with default permalinks

  • Resolved shreya08

    (@shreya08)


    Hi,
    I changed my domain name for my website and I double checked with the migration document on WordPress, everything is as it should be.
    Problem:
    When permalinks is set to default:
    all pages work, expect for a button on homepage which sends me back to the homepage but updates URL. For Example, im on example.com and i press search button>> URL changes to example.com/search but im on the same homepage. I press it again , URl becomes example.com/search/search . Interesting and Frustrating.

    When permalinks are set to other settings like day, month.
    Some pages redirect to old domain. Example: if i click on search on my website , it will take me to oldexample.com/search. when i manually update URL to example.com/search, I can see the page. BTW, oldexample/search gives me nothing.

    Recently, I activated all in one seo and sitemaps dont work with default permalinks. Example: example.com/sitemap.xml gives me my homepage instead of the sitemap page. When i change the permalinks to other settings, I can see my sitemap.
    I mean, what is this??
    Please help.
    PS: Its a multisite installation with ONLY 1 SITE. and I had W3 cache, deleted it. problem exists.
    PSS: when i submit my sitemap.xml to google with default permalinks, it says its HTML. so i changed permalink to date month and submitted; Successfully.

Viewing 1 replies (of 1 total)
  • Installed the search and replace script as suggested by someone in stackoverflow. Followed the instructions, found out that wp-postmeta had some URLs that still pointed to old domain name.
    updating those with new URL did the trick. I can access my sitemap and other pages with day,month permalinks settings.

Viewing 1 replies (of 1 total)
  • The topic ‘Sitemaps don't work with default permalinks’ is closed to new replies.