WordPress.org

Forums

WordPress SEO by Yoast
sitemap xml white page (18 posts)

  1. ptiper21
    Member
    Posted 1 year ago #

    Hi. I have the latest version of yoast seo plugin, and i see that xml sitemap page : /sitemap_index.xml is just white - no content.

    Also i tested other sitemap pages and all are blank-white pages. Is there a problem with xml sitemap?

    https://wordpress.org/plugins/wordpress-seo/

  2. cmwwebfx
    Member
    Posted 1 year ago #

    Hi there,

    I can confirm that the xml sitemap is no longer being created with the plugin. This used to happen on all sites. I have just created a new site and installed the plugin and the sitemap is not being created.

    When I go to check the sitemap.xml, it is redirecting to sitemap_index.xml and then showing 404 page not found.

    Is this a bug?

  3. ptiper21
    Member
    Posted 1 year ago #

    i think we have to choose another serious plugin for sitemap... many times updates of yoast break the sitemap function again and again. i am bored!

  4. Enviro2B
    Member
    Posted 1 year ago #

    Hi, same problem as you with /news-sitemap.xml since few days and it sucks !!!
    Help please

  5. Li-An
    Member
    Posted 1 year ago #

    Same here on a test blog - Twenty Fourty and no other plugin.

  6. cmwwebfx
    Member
    Posted 1 year ago #

    For nw a workaround is to install this plugin:
    http://wordpress.org/plugins/google-sitemap-generator/

    Once installed it will create the new sitemap.xml, then go back to your WordPress SEO sitemap settings, re-save that page, and your sitemap index will now be available in it's entirety. The issue is that the WordPress SEO plugin is not creating the initial sitemap.xml. This workaround works perfect.

    Hopefully the Yoast crew will fix the issue soon. if not, this way will work for you.

  7. peteralt
    Member
    Posted 1 year ago #

    I tried your fix and i get the same error messge:

    o Results Found
    The page you requested could not be found. Try refining your search, or use the navigation above to locate the post.

  8. peteralt
    Member
    Posted 1 year ago #

    I am trying to use the Yoast SEO xml settings. So I am confused why I would install another xml sitemap?

  9. ottomek
    Member
    Posted 1 year ago #

    I installed yoast on a new site and the xml sitemap url was not workging.
    Hit save a couple times and still didn't work.

    I unchecked the "Check this box to enable XML sitemap functionality." and hit save. Then I checked this box and hit save. Sitemap url started working.

  10. blaise25
    Member
    Posted 1 year ago #

    I have 2 sites using WordPress 3.8.1 -one using the latest WP SEO plugin, the other one using 1.4.24. My site's sitemap with 1.4.24 is fine and working. My new site using this new plugin is working too according to Google Webmaster Tools (everything is indexed) however when I open the sitemap URL I can only see white page displaying only my sitemaps URL... I asked Synthesis support about this and they told me sitemap is Ok, the only problem is W3 Total Cache + Yoast Updated Version. Seems that having them both have page display issue with Yoast Sitemap.

    I think I will wait for the solution of this. At least everything is indexing for now

  11. Adam W. Warner
    Member
    Posted 1 year ago #

    Same issue here. Sitemap = 404 page after latest WordPress SEO update.

  12. li9ssb
    Member
    Posted 1 year ago #

    I want to confirm information about generating the sitemap.
    This part of the plugin does not work in version 3.8.1.

  13. ottomek
    Member
    Posted 1 year ago #

    I've had success unchecking the XML sitemap feature in yoast and saving the settings. Then when I check it again and save the XML sitemap works.

    I've done this on 4 of my sites that were having issues with the upgrade.

    Does this work for anyone else?

  14. quidprocrow
    Member
    Posted 1 year ago #

    I'm using 1.5.2.5 Checking and unchecking did not work for me. Without sitemaps I immediately lose SEO rankings. What's up?

  15. quidprocrow
    Member
    Posted 1 year ago #

    Let me clarify sitemap_index.xml shows a 404 on webmaster tools. All the other maps, category, page, post, post_tag and geo don't show errors. Interestingly, I noted that my rankings had slipped today.

  16. donwilson
    Member
    Posted 1 year ago #

    If you click the Save button on the Permalinks page under Tools, that'll refresh the permalink rules for the entire blog. Yoast probably changed a permalink rule and forgot to include a permalink refresh in the update function.

  17. donwilson
    Member
    Posted 1 year ago #

    Update: It looks like it breaks the sitemap permalink every time you save something in the Yoast plugin, so go into Permalinks and click Save after changing a setting in Yoast for now.

  18. quidprocrow
    Member
    Posted 1 year ago #

    That worked! Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic